Bug 110167 - Menu checkbox in Grand-Canyon theme has wrong state
Summary: Menu checkbox in Grand-Canyon theme has wrong state
Status: CLOSED DUPLICATE of bug 89467
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-themes (Show other bugs)
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-15 20:25 UTC by Need Real Name
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2003-11-15 20:25:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030 Galeon/1.3.10

Description of problem:
When using Grand-Canyon "controls" theme the state of menu checkmarks
are backwards. They appear checked when unchecked and checked when
unchecked.

Version-Release number of selected component (if applicable):
gnome-themes-2.4.0-1

How reproducible:
Always

Steps to Reproduce:
1. Open Theme preference.
2. Choose "Grand Canyon" theme.
3. Open Nautilus, click on the View menu.


Actual Results:  Observe that the state of the Side Pane/Location
Bar/Toolbar/etc are backwards. (Note that this is not a
Nautilus-specific bug.)


Expected Results:  


Additional info:

To fix, swap the pngs that Grand-Canyon's gtkrc uses for the menu
checkmarks.

--- gtkrc       2003-11-15 11:17:42.122436208 -0800
+++ gtkrc.patch 2003-11-15 11:16:26.505931664 -0800
@@ -291,7 +291,7 @@
        function        = CHECK
        recolorable     = TRUE
        shadow          = OUT
-       overlay_file    = "check2.png"
+       overlay_file    = "3d_all_normal.png"
        overlay_stretch = FALSE
       }
     image
@@ -299,7 +299,7 @@
        function        = CHECK
        recolorable     = TRUE
        shadow          = IN
-       overlay_file    = "3d_all_normal.png"
+       overlay_file    = "check2.png"
        overlay_stretch = FALSE
       }
     image

Comment 1 Jeff Moe (jebba) 2004-07-13 02:45:03 UTC
This bug exists in Fedora Core 2 as well (gnome-themes-2.6.0-2).

Comment 2 Alexander Larsson 2004-10-05 14:13:25 UTC

*** This bug has been marked as a duplicate of 89467 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:00:01 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.