Bug 110187 - Metacity occasionally shows ALL windows on a single workspace when Alt-Tabbing
Metacity occasionally shows ALL windows on a single workspace when Alt-Tabbing
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-16 13:13 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-01 17:15:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-11-16 13:13:02 EST
Description of problem:
I use the Metacity window manager on a system upgraded from RHL9.  I
use 4 workspaces (which is the default).

Occasionally, when I press Alt-Tab (after releasing the keys) to
switch between windows, my disk will start grinding and all the
windows of all 4 workspaces will briefly (a few seconds) appear at
once (I believe they appear without their window decorations, i.e.,
close buttons, title bars, etc.) .  After it settles down, everything
seems to be working normally again.

There doesn't seem to be any harmful impact, except for the annoyance
and unusability while this is happening.  I usually have to wait about
5-10 secs. for it to clear up (Athlon 750, 512M RAM).

Version-Release number of selected component (if applicable):
2.6.3-1

How reproducible:
Occasionally (about once every few days).

Steps to Reproduce:
Unfortunately, I do not yet know how to reproduce this.  It appears to
be random.  If I find a way to trigger it, I will post more info to
this thread.
  
Actual results:
Session unusable until the problem goes away.

Expected results:
Windows should switch normally.

Additional info:
Never happened on RHL9.

Thanks.
Comment 1 Paul M Edwards 2003-12-06 03:19:38 EST
I'm experiencing something very similar to this on my box (Athlon 1
GHz currently underclocked to 750 MHz w/512 MB RAM & a Radeon 9000 Pro
128 MB DDR if it matters).

On my box, this happens occasionally when I switch to a different
workspace. I've never experienced it when alt-tabbing.

When it happens to me, all of my windows (except GKrellM) on every
workspace is shifted down and to the right a bit, as if they are being
repositioned - like when a new app is launched. I don't remember if
there is any swap paging going on during this, but I will try to pay
attention to that an re-comment if it is doing so.
Comment 2 Need Real Name 2003-12-17 14:43:00 EST
Ditto that, I do also get it when switching workspaces at times.  Same
behavior with the moved windows as well.  They move down what seems to
be the height of the title bar.  IOW, if the title bar is 0.5cm from
the  top of the screen, the windows will get nudged down 0.5cm.

Note that the disk grinding I noted isn't necessarily swap paging; I
haven't been able to tell yet whether it's doing swapping, or a bunch
of filesystem i/o.
Comment 3 Mace Moneta 2004-01-14 21:18:01 EST
I'm also seeing this.  I also assigned keyboard shortcuts for switch
to workspace 1,2,3,4, and it happens (sometimes) when using those as
well.  I also see the windows shifting, which is the most annoying
part of this bug for me (I keep a dozen windows arranged on different
workspaces, and the shift is time comsuming to correct).

One other item... I noticed that this also happens (frequently) when I
close a sticky window.  I typically have seven sticky windows (4
gkrellm monitors and three gnome terminal).  I hope that helps track
this very annoying bug down.
Comment 4 dexterthrowaway 2004-03-21 10:14:59 EST
I've had these happen to me whenever I close a window. Every window
content shows up on the desktop (without the borders). Then everything
disappears, and moves slight lower and to the right. I've had this
happen whenever I close a gnome terminal or a nautilus window. I
haven't noticed this happen with other windows.

I have never had this happen when switching workspaces. And I've never
had these happen consistently.

A question to Comment #3, what is a sticky window? Is that when you
put the window on all workspaces?
Comment 5 Mace Moneta 2004-03-21 11:02:07 EST
Dexter Ang: Yes, most window managers use the term "sticky" when
refering to this attribute, which Metacity calls "Put on all workspaces".
Comment 6 Paul M Edwards 2004-03-21 19:56:09 EST
It's apparent that the cause of what we are seeing is Metacity
crashing and automatically reloading.

I have reproduced the effect by manually killing the Metacity process.

The question is why is it crashing?
Comment 7 David Baron 2004-03-21 20:56:56 EST
The metacity crash when closing windows is bug 106357.

The crash when switching windows or workspaces may be the same crash
but may be different -- a stack might tell.
Comment 8 Bill Nottingham 2004-05-21 17:06:10 EDT
Does this happen with FC2?
Comment 9 Havoc Pennington 2004-05-25 16:31:16 EDT
Please reopen if still in FC2.
Comment 10 Need Real Name 2004-08-01 17:15:43 EDT
So far it has not happened with FC2, which I have been running since a
few days after it was released.

Note You need to log in before you can comment on or make changes to this bug.