Bug 106357 - closing apps may crash WM
closing apps may crash WM
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
: Triaged
: 110548 (view as bug list)
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-10-06 10:06 EDT by Alexandre Oliva
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-25 15:42:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2003-10-06 10:06:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031002

Description of problem:
metacity-2.6.2-1 fixed bug 104442 (thanks!), but it introduced a new problem :-(

I still haven't been able to come up with a list of steps that can be used to
duplicate it, but I've noticed that, quite often, as I manually close windows
I've opened, just before logging out (I close them by hand to verify I haven't
left anything behind), it will sometimes crash.  Applications I typically have
opened on my desktops are GNU Emacs, gnome-terminal, xchat and Mozilla.  I still
don't know whether the metacity crash is related with any of the apps, or with
something weird I might be doing, or what, but this is a heads up that something
is broken.  I'll post more details as I find them out.

Version-Release number of selected component (if applicable):
metacity-2.6.2-1

How reproducible:
Sometimes

Steps to Reproduce:
1.Open a number of windows over several desktops
2.Start closing them

Actual Results:  WM sometimes crashes

Expected Results:  It shouldn't

Additional info:
Comment 1 Alexandre Oliva 2003-10-25 15:39:57 EDT
I haven't got this any more with recent updates.  Dunno exactly what fixed it,
but it seems to be gone.
Comment 2 Alexandre Oliva 2003-10-26 11:31:36 EST
Spoke a bit too soon :-(  It's back.

Seems to happen most often when closing xchat, but it's not easily reproducible :-(
Comment 3 Alexandre Oliva 2003-10-31 18:49:15 EST
Got it closing gnome-terminal the other day, and closing Mozilla today
:-(  It doesn't seem to be related with the application.
Comment 4 Mikko Paananen 2003-12-02 12:52:39 EST
$ rpm -q metacity 
metacity-2.6.3-1
$ file core.*
core.13227: ELF 32-bit LSB core file Intel 80386, version 1 (SYSV),
SVR4-style, SVR4-style, from 'metacity'
core.17275: ELF 32-bit LSB core file Intel 80386, version 1 (SYSV),
SVR4-style, SVR4-style, from 'metacity'
core.20403: ELF 32-bit LSB core file Intel 80386, version 1 (SYSV),
SVR4-style, SVR4-style, from 'metacity'

$ gdb `which metacity` core.13227
...
(gdb) bt
#0  0x00c159d0 in g_list_find () from /usr/lib/libglib-2.0.so.0
#1  0x0809fd0b in meta_workspace_contains_window ()
#2  0x0809671d in meta_window_visible_on_workspace ()
#3  0x080967c0 in meta_window_visible_on_workspace ()
#4  0x080969b4 in meta_window_calc_showing ()
#5  0x08098ec8 in meta_window_focus ()
#6  0x080a0c60 in meta_workspace_focus_mru_window ()
#7  0x08096485 in meta_window_free ()
#8  0x0805f54e in meta_display_get_current_time ()
#9  0x080934f8 in meta_ui_get_display ()
#10 0x0834b130 in ?? ()
#11 0xbfec5768 in ?? ()
#12 0x0032a668 in gdk_event_get_graphics_expose ()
   from /usr/lib/libgdk-x11-2.0.so.0
#13 0x0070a020 in ?? () from /lib/tls/libc.so.6

2nd:
#0  0x08098eb3 in meta_window_focus ()
#1  0x080a0c60 in meta_workspace_focus_mru_window ()
#2  0x08096485 in meta_window_free ()
#3  0x0805f54e in meta_display_get_current_time ()
#4  0x080934f8 in meta_ui_get_display ()
#5  0x0993ce80 in ?? ()
#6  0xbff4b358 in ?? ()
#7  0x0032a668 in gdk_event_get_graphics_expose ()
   from /usr/lib/libgdk-x11-2.0.so.0
#8  0x003c85fa in gtk_clist_set_button_actions ()
   from /usr/lib/libgtk-x11-2.0.so.0
Previous frame inner to this frame (corrupt stack?)

3rd:
#0  0x08098ea9 in meta_window_focus ()
#1  0x080a0c60 in meta_workspace_focus_mru_window ()
#2  0x08096485 in meta_window_free ()
#3  0x0805f54e in meta_display_get_current_time ()
#4  0x080934f8 in meta_ui_get_display ()
#5  0x09252e80 in ?? ()
#6  0xbfe36ed8 in ?? ()
#7  0x0032a668 in gdk_event_get_graphics_expose ()
   from /usr/lib/libgdk-x11-2.0.so.0
#8  0x0036eddc in ?? () from /usr/lib/libgtk-x11-2.0.so.0
Comment 5 David Baron 2004-02-26 19:35:20 EST
I'm seeing a stack like the last two, and it looks like the crash is
because window is trashed, so window->display is a pointer off in the
weeds, so testing window->display->grab_window crashes (segmentation
fault).
Comment 6 Bart Martens 2004-03-03 01:28:16 EST
*** Bug 110548 has been marked as a duplicate of this bug. ***
Comment 7 Bart Martens 2004-03-03 01:33:55 EST
Changing version to 1.
Comment 8 Havoc Pennington 2004-05-25 15:42:58 EDT
Same as http://bugzilla.gnome.org/show_bug.cgi?id=143149 presumably.

Note You need to log in before you can comment on or make changes to this bug.