Bug 110228 - nfs automount stale handles
nfs automount stale handles
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
:
: 113338 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-17 05:22 EST by Trausti Thor Johannsson
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-20 17:14:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trausti Thor Johannsson 2003-11-17 05:22:55 EST
Description of problem:

After a while, our nfs clients (using autofs) will stop working, and 
we will have stale handles all over the place, in most cases to have 
the affected people log out and then umount the directory in question 
and/or /etc/init.d/autof reload/restart will sometimes work, but 
after that the problem will come back very shortly.  This 
happens everytime when people want to start compiling (over nfs) and 
use vnc and such over nfs.  We are only a 300 people software company 
and have 3 fileservers (big ones), so I think this is abnormal.

This happens on all our 7.X boxes and redhat AS 2.1, kernel versions 
don't seem to matter, we are currently running the latest ones 
2.4.20-18.7 (smp where appliceble) and kernel-enterprise-2.4.9-e.25.
But some boxes are running older kernels.

This has serious problems for us.

Version-Release number of selected component (if applicable):
Ad 2.1
RH 7.3

How reproducible:

There seems to be very little rule as to how to make this happen, 
this happens all the 
time, when we are working over nfs.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeffrey Moyer 2004-03-23 12:48:10 EST
Please attach the log messages indicating the problem.

Thanks.
Comment 2 Steve Dickson 2004-06-29 13:56:29 EDT
*** Bug 113338 has been marked as a duplicate of this bug. ***
Comment 3 Suzanne Hillman 2004-10-20 17:14:24 EDT
This bug never had a reply, and it's been in NEEDINFO for... about 7 months. I'm
closing it. Please reopen if there is more information available.

Note You need to log in before you can comment on or make changes to this bug.