Bug 110280 - rhn-applet blocks logging out in GNOME for 1 minute
rhn-applet blocks logging out in GNOME for 1 minute
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: rhn-applet (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-17 15:30 EST by Jaap Haitsma
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-04 16:17:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaap Haitsma 2003-11-17 15:30:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031110 Firebird/0.7

Description of problem:
I have a lapto with Fedora core 1, which I use with a direct
connection to the Internet (at home) or with a proxy (at work). I have
rhn-applet configured without a proxy. With a direct connection at
home everything is working fine.
However if I use my laptop at work and then want to log out of GNOME,
the logging out hangs for about 1 minute. I guess some time out in
rhn-applet is causing this, because when I first stop rhn-applet
manually logging out goes fast. When the logging out is hanging I saw
in another terminal that rhn-applet was still running and when I
killed it my Gnome Session immediately logged out.

NOTE with this behaviour behind a proxy I still have the applet
configured with a direct connection to the internet. I works fine if I
select the appropriate proxy. However I'm to lazy to change this (and
also forget this ) every time.

A suggestion which would make life more easy for me would be to use an
automatic configuration script. I do this with mozilla. When mozilla
does not find this script it just assumes it has a direct connection.
That way it automagically works at home and at work.

Furthermore isn't there a way such that applications can get the proxy
settings from the Network Proxy settings in the Gnome Preferences
menu. (I guess KDE has something similar). This would save a lot of
setting proxies in different programs.

Version-Release number of selected component (if applicable):
rhn-applet-2.1.4-1

How reproducible:
Always

Steps to Reproduce:
1. Choose no proxy in rhn_applet
2. Connect your PC to a network with a proxy
3. Start up gnome
4. Log out of gnome
    

Actual Results:  It hangs for about a minute

Expected Results:  Immediate logout

Additional info:
Comment 1 chris 2004-01-29 12:20:09 EST
Can you upgrade to the latest rhn-applet and see if that stil occurs?

You can get it here:
ftp://download.fedora.redhat.com//pub/fedora/linux/core/updates/1/i386/rhn-applet-2.1.4-3.i386.rpm

Also, check your proxy settings.  There seems to be issues with
rhn-applet an proxy servers.  See bug 107315 and bug 114085.

If it works after the upgrade let us know.
Comment 2 Jaap Haitsma 2004-01-30 04:23:53 EST
Still exactly the same behaviour

Note You need to log in before you can comment on or make changes to this bug.