Bug 1102878 - Capsule: need method of restarting capsule services, akin to 'katello-services'
Summary: Capsule: need method of restarting capsule services, akin to 'katello-services'
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Capsule
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Stephen Benjamin
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1120845 (view as bug list)
Depends On: 1220309
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker
TreeView+ depends on / blocked
 
Reported: 2014-05-29 18:21 UTC by Corey Welton
Modified: 2019-08-15 03:50 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Release Note
Doc Text:
To fully restart a capsule, the following servcices will need to be restarted: foreman-proxy qpidd pulp_celerybeat pulp_workers pulp_resource_manager httpd
Clone Of:
Environment:
Last Closed: 2015-08-12 14:02:38 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1187883 None None None Never

Description Corey Welton 2014-05-29 18:21:02 UTC
Description of problem:
When we want to restart a slew of services in sat6, we can use 'katello-services restart'.  There does not appear to be a method of easily doing this sort of thing for capsules.

Version-Release number of selected component (if applicable):

Satellite-6.0.3-RHEL-6-20140529.0



Steps to Reproduce:
1.  Decide you want to try and restart capsule services
2.  ???


Actual results:
no way.

Expected results:
Profit!
(or be able to easily restart capsule related services)

Additional info:

Comment 2 Jan Hutař 2014-07-03 11:51:23 UTC
Do we want katello-service to restart capsule services automatically in case capsule is installed on same system as Satellite 6 server?

Comment 3 Stephen Benjamin 2014-07-25 11:01:53 UTC
Created redmine issue http://projects.theforeman.org/issues/6781 from this bug

Comment 4 Eric Helms 2014-08-06 11:35:32 UTC
*** Bug 1120845 has been marked as a duplicate of this bug. ***

Comment 6 Stephen Benjamin 2014-11-17 10:48:17 UTC
We had a couple of conversations upstream on the mailing list, and I'm not really sure I see the value of this.

A Capsule can manage a dozen different services, many of which may be external to the capsule.  Also, all of the services are not really related, so I can't really ever see a case that some change is going to need you to restart, say, DHCP and Pulp at the same time - it's far too big a hammer.  

Restart foreman-proxy, or the particular service you're working on (e.g. named).

The main issue it seems is just pulp, so perhaps a bug should go to pulp to provide a tool to restart all the content-related services in the right order.

Comment 7 Xixi 2014-11-25 00:46:49 UTC
(In reply to Stephen Benjamin from comment #6)
> We had a couple of conversations upstream on the mailing list, and I'm not
> really sure I see the value of this.
> 
The gap is there's no equivalent of katello-service for Capsule (whereas Satellite 6, Satellite 5, and Satellite Proxy 5 all have a single command to restart Satellite or Proxy services).

One use case for example is when applying errata to a Capsule server and needing to restart services.  Mike just wrote https://access.redhat.com/solutions/1276863 "How do I apply errata updates to my Satellite 6 Server or Capsule?" which will be referenced by all Satellite 6/Capsule errata going forward as part of the instructions, and this references the attached https://access.redhat.com/solutions/1187883 for steps (thanks Justin) how to stop/start Capsule services.  What's missing still though is the actual utility to do this.

> A Capsule can manage a dozen different services, many of which may be
> external to the capsule.  Also, all of the services are not really related,
> so I can't really ever see a case that some change is going to need you to
> restart, say, DHCP and Pulp at the same time - it's far too big a hammer.  
> 
> Restart foreman-proxy, or the particular service you're working on (e.g.
> named).
> 
> The main issue it seems is just pulp, so perhaps a bug should go to pulp to
> provide a tool to restart all the content-related services in the right
> order.
Is there a way to automatically detect if these services are being used, or provide user an option whether to include these services (named/dhcp) in stop/start?  Failing that, we could print out a message for the user either to manually restart those, or restart them and let the user be aware.

Thanks,
Xixi

Comment 8 Xixi 2014-11-25 00:48:08 UTC
including a snapshot of https://access.redhat.com/solutions/1187883 for reference:

"
Resolution

In some instances it is necessary to manually stop and then restart the Capsule services.
One method is to reboot the Capsule
You may also individually stop, start, or restart the services using;

service <service name> stop | start | restart

    The affected services include;
        dhcpd
        dns
        httpd
        pulp_celerybeat
        pulp_workers
        pulp_resource_manager
        foreman_proxy

To restart the pulp, foreman-proxy, and puppet master portions:

for i in pulp_celerybeat pulp_resource_manager pulp_workers httpd foreman-proxy; do service $i stop; done
for i in pulp_celerybeat pulp_resource_manager pulp_workers httpd foreman-proxy; do service $i start; done

if using the dns feature or dhcp feature, simply restart their respective services:

service named restart
service dhcpd restart

"

Comment 12 Bryan Kearney 2015-01-29 19:02:08 UTC
Upstream bug assigned to stbenjam@redhat.com

Comment 15 Stuart R. Kirk 2015-04-27 14:55:50 UTC
The foreman service should be "foreman-proxy" and *not* "foreman_proxy"  Note: dash instead of underscore.

Comment 16 Bryan Kearney 2015-04-29 20:01:58 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6781 has been closed
-------------
Anonymous
Applied in changeset commit:katello|3e035bf0e6d7623a825bbdf586f330f5021c8e3f.

Comment 17 Bryan Kearney 2015-04-29 20:18:51 UTC
ALSO pull in https://github.com/Katello/katello-installer/pull/217

Comment 22 Tazim Kolhar 2015-05-11 11:11:23 UTC
hi 

please provide verification steps

thanks

Comment 23 Stephen Benjamin 2015-05-11 11:46:50 UTC
This is currently blocked, but steps would be:

1. Run `katello-service status` on a capsule

2. You'll get the status of all the services, it will look something like this, but depends on the features you've enabled and the OS:


mongod (pid  23580) is running...
listening on 127.0.0.1:27017
connection test successful
celery init v10.0.
Using config script: /etc/default/pulp_resource_manager
node resource_manager (pid 23799) is running...
celery init v10.0.
Using config script: /etc/default/pulp_workers
node reserved_resource_worker-0 (pid 23993) is running...
node reserved_resource_worker-1 (pid 24018) is running...
node reserved_resource_worker-2 (pid 24047) is running...
node reserved_resource_worker-3 (pid 24074) is running...
node reserved_resource_worker-4 (pid 24105) is running...
node reserved_resource_worker-5 (pid 24134) is running...
node reserved_resource_worker-6 (pid 24163) is running...
node reserved_resource_worker-7 (pid 24192) is running...
celery init v10.0.
Using configuration: /etc/default/pulp_workers, /etc/default/pulp_celerybeat
pulp_celerybeat (pid 24248) is running.
httpd (pid  24288) is running...

Comment 24 Bryan Kearney 2015-05-11 18:23:25 UTC
moving to modified to reflect the dependency on https://bugzilla.redhat.com/show_bug.cgi?id=1220309

Comment 26 Tazim Kolhar 2015-05-21 12:15:37 UTC
hi

here this bz is dependent on 
https://bugzilla.redhat.com/show_bug.cgi?id=1220309
hence once this is verified can proceed further
thanks

Comment 27 Tazim Kolhar 2015-06-04 11:46:58 UTC
hi

here this bz is dependent on 
https://bugzilla.redhat.com/show_bug.cgi?id=1228195
hence once this is verified can proceed further
thanks

Comment 28 Corey Welton 2015-06-11 15:45:49 UTC
Removing dependency on bug 1228195 as I am not sure it is a legit bug.  I installed compose from latest capsule just fine

Comment 29 Corey Welton 2015-06-11 19:39:37 UTC
taking this bz.  Verified in snap 8

Comment 30 Bryan Kearney 2015-08-11 13:28:16 UTC
This bug is slated to be released with Satellite 6.1.

Comment 31 Bryan Kearney 2015-08-12 14:02:38 UTC
This bug was fixed in version 6.1.1 of Satellite which was released on 12 August, 2015.


Note You need to log in before you can comment on or make changes to this bug.