Bug 1102901 - mupdf bundles curl and openjpeg
mupdf bundles curl and openjpeg
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mupdf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Zhukov
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: DuplicSysLibsTracker
  Show dependency treegraph
 
Reported: 2014-05-29 15:14 EDT by Ville Skyttä
Modified: 2014-06-30 07:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-30 06:25:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2014-05-29 15:14:52 EDT
https://fedoraproject.org/wiki/Packaging:No_Bundled_Libraries
https://fedoraproject.org/wiki/Packaging:Treatment_Of_Bundled_Libraries

Bug #1102898 handles a bunch of others, but still leaves bundled curl and openjpeg to be taken care of.
Comment 1 Ville Skyttä 2014-06-30 05:37:44 EDT
1.5-2 effectively just removes curl support. "BuildRequires: curl-devel" is required to add it back.
Comment 2 Pavel Zhukov 2014-06-30 06:25:50 EDT
This bug is fixed. If you complain about curl support - feel free to open another one.

Thank you!
Comment 3 Ville Skyttä 2014-06-30 07:16:45 EDT
Sigh. That's not a very productive use of either of our time. You could just have added the curl-devel build dep or told me to do it myself, but since you seem to insist, here you go: bug 1114566

Note You need to log in before you can comment on or make changes to this bug.