Bug 1114566 - Be explicit about curl support
Be explicit about curl support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mupdf (Show other bugs)
rawhide
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Pavel Zhukov
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-06-30 07:16 EDT by Ville Skyttä
Modified: 2016-10-31 02:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-28 15:27:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2014-06-30 07:16:08 EDT
Since you asked in bug 1102901:

mupdf compiles in curl support if curl-devel is installed.

If that's desirable, it needs to be made explicit for reproducible builds by adding BuildRequires: curl-devel.

If that's not desirable, that needs to be made explicit too, either by adding BuildConflicts: curl-devel or otherwise ensuring that curl support is not built in even if curl-devel is installed.
Comment 1 Ville Skyttä 2014-07-04 19:45:04 EDT
1.5-3 changelog mentions adding curl-devel BR, but doesn't actually add it.

http://pkgs.fedoraproject.org/cgit/mupdf.git/commit/?id=c5c814f
Comment 2 Dominik 'Rathann' Mierzejewski 2016-08-02 16:24:31 EDT
This still not fixed, please do not close until it is.
Comment 3 Pavel Zhukov 2016-10-28 15:27:13 EDT
As I can see this was fixed 2 years ago:
http://pkgs.fedoraproject.org/cgit/rpms/mupdf.git/commit/?id=fbcd9c181f72e828e53be544812d7dc9cf837fc4

Did I miss something?
Comment 4 Dominik 'Rathann' Mierzejewski 2016-10-30 21:40:13 EDT
Indeed it was, thanks. It would've been easier to see if the dependencies were specified one per line and sorted.
Comment 5 Pavel Zhukov 2016-10-31 02:31:44 EDT
(In reply to Dominik 'Rathann' Mierzejewski from comment #4)
> Indeed it was, thanks. It would've been easier to see if the dependencies
> were specified one per line and sorted.

Please use grep next time.

Note You need to log in before you can comment on or make changes to this bug.