Bug 1103181 - Repositories associated with content view not shown
Summary: Repositories associated with content view not shown
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Tazim Kolhar
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1108732 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-30 12:34 UTC by Matej Kollar
Modified: 2019-09-26 18:14 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:19:02 UTC
Target Upstream Version:


Attachments (Terms of Use)
Data for reproducer. (2.28 MB, application/x-gzip)
2014-06-03 09:32 UTC, Matej Kollar
no flags Details
Reproducer.rb (893 bytes, application/x-ruby)
2014-06-03 12:21 UTC, Matej Kollar
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 6459 0 None None None 2016-04-22 15:03:04 UTC

Description Matej Kollar 2014-05-30 12:34:51 UTC
Description of problem: Navigating to

  Content -> Content views
  -> <Particular content view>
  -> Content -> Repositories
  -> List/Remove

Does not sow any repositories, even though:

  * Through Hammer I can see them
  * When I close content view, I can (in the listing)
    see number (> 0).

How reproducible: always

Steps to Reproduce:

  1. Create product, create repository, create content-view
  2. Associate repository with content view
  3. observe

Actual results:

  No repositories are listed

Expected results:

  Repositories are listed


Additional info:

  * via API (Hammer) I can see they are associated
  * It may work for some time, but break eventually
  * no error is in production.log when accessing page

Comment 2 RHEL Program Management 2014-05-30 12:55:02 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Brad Buckingham 2014-06-02 17:50:54 UTC
Hi Matej, can you provide more details on the scenario that led to the behavior that you see?

Comment 5 Matej Kollar 2014-06-03 09:30:08 UTC
On freshly installed sat6 I just call some APIs... to be more precise:

I use https://github.com/Katello/hammer-cli-import (ad0044d077)

and import organizations, users, repositories, content-views and then I have described state.

    hammer import organization --csv-file exports/report-users.csv
    hammer import user --csv-file exports/report-users.csv
    hammer import repository --csv-file exports/report-repositories.csv --sync --synchronous
    hammer import content-view --csv-file /tmp/x-port/export.csv --sync --synchronous

I'll attach content of CSVs.

Additional info: I was unable to achieve it via WebUI (when I tried now).

Comment 7 Matej Kollar 2014-06-03 09:32:53 UTC
Created attachment 901716 [details]
Data for reproducer.

Comment 8 Matej Kollar 2014-06-03 12:20:50 UTC
Ok, I have shrunk reproducer a little... see attached.

Comment 9 Matej Kollar 2014-06-03 12:21:42 UTC
Created attachment 901763 [details]
Reproducer.rb

Comment 10 Partha Aji 2014-07-01 17:21:13 UTC
This should be fixed when https://github.com/Katello/katello/pull/4371 gets pushed.

Comment 11 Partha Aji 2014-07-01 17:24:10 UTC
Created redmine issue http://projects.theforeman.org/issues/6459 from this bug

Comment 12 Partha Aji 2014-07-01 18:16:11 UTC
*** Bug 1108732 has been marked as a duplicate of this bug. ***

Comment 14 Tazim Kolhar 2014-08-08 10:39:35 UTC
VERIFIED

Comment 16 Bryan Kearney 2014-09-11 12:19:02 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.