Bug 110332 - Sticky keyboard keys when ACPI is on and CPU temperature is too high
Sticky keyboard keys when ACPI is on and CPU temperature is too high
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-18 11:10 EST by Julien Olivier
Modified: 2015-01-04 17:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-22 05:29:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julien Olivier 2003-11-18 11:10:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031030

Description of problem:
On my Fujitsu/Siemens Amilo D laptop, if I activate ACPI (using
acpi=on in /etc/grub.conf) and CPU gets too hot, the keyboard becomes
"sticky". That means, that keys keep repeating for a few second after
you've stop pressing them.

That happens with acpid running as well as with acpid stopped but it
doesn't happen when acpi is disabled in the kernel.

Tha bad news for you (but good news for me) is that I have fixed my
CPU fan. So I can't reproduce the problem anymore because I can't
reach the critical temperature (79 Celsius).

Please see Bug #74635 for more information.

Version-Release number of selected component (if applicable):
kernel-2.4.22-1.2088.nptl

How reproducible:
Always

Steps to Reproduce:
1.append "acpi=on" in /etc/grub.conf
2.break/remove your CPU fan
3.launch a CPU-using application (any compilation or video game)
4.wait until CPU temperature reaches the "critical" temperature (as
stated by "cat /proc/acpi/thermal_zone/THR1/trip_points")
5.Try typing anything in a terminal

Actual Results:  Some letters will be repeated while you didn't intend
to repeat them, giving sentences like: ttthiiiiis iss    
jjjjusssssttt a   tesstttt...

Expected Results:  Nothing should happen.

Additional info:

Bug #74635 contains more information.
Comment 1 Julien Olivier 2004-03-12 10:34:26 EST
It's been a while sinc I had this bug, and it re-appeared today.

And, actually, it was the first time since long that I used my laptop
with the battery plugged in (I usually use it without the battery).

After removing the battery, the bug disappeared.
Comment 2 Len Brown 2004-03-12 22:47:09 EST
so this happens only when
1. ACPI is enabled
2. battery is present
3. fan is broken
and the temperature exceeds the critical shutdown temperature of 79C?

pleaase capture the contents of the files 
under /proc/acpi/thermal_zone when this is happening, and when it is 
not happening.

Can you verify that it still happnes with the 2.6-based FC2?

thanks,
-Len

Comment 3 Julien Olivier 2004-03-13 04:42:59 EST
Well, I've not been very complete in my last report. Here is exactly
what I noticed:

The "sticky keys" phenomenom appears when:

 - ACPI is enabled
 - temperature exceeds 79°C
 - the battery is plugged or un-plugged

The new thing is that I saw it happen too when:

 - ACPI is *disabled*
 - the battery is plugged

In the second case, I don't know what the temperature, because I don't
know how to get such information without ACPI enabled. That said, I
had been working for about 3 or 4 hours on my laptop (mostly
programming involving compilation and, thus, heavy CPU usage) when it
happened. So I guess the temperature was a bit high.
Is there a way  to get the temperature without ACPI ?

Note that, maybe my laptop's temperature tends to grow faster when
ACPI is off and the battery is plugged... that would explain why, when
ACPI is off, it only happens with the battery plugged. But what's
stranger is that removing the battery immediately made the bug go
away, without rebooting or waiting for the laptop to "calm down"...

For more information, I captured the files 
under /proc/acpi/thermal_zone during an intensive compilation session,
*with ACPI on*:

--
[root@localhost julien]# ls /proc/acpi/thermal_zone/*
/proc/acpi/thermal_zone/THR1:
cooling_mode  polling_frequency  state  temperature  trip_points
 
/proc/acpi/thermal_zone/THR2:
cooling_mode  polling_frequency  state  temperature  trip_points
[root@localhost julien]# cat /proc/acpi/thermal_zone/*/*
<not supported>
<polling disabled>
state:                   ok
temperature:             61 C
critical (S5):           78 C
<not supported>
<polling disabled>
state:                   ok
temperature:             53 C
critical (S5):           72 C
[root@localhost julien]# watch cat /proc/acpi/thermal_zone/*/*
Every 2s: cat /proc/acpi/thermal_zone/THR1/cooling_...  Sat Mar 13
09:30:04 2004                                                        
                       
<not supported>
<polling disabled>
state:                   ok
temperature:             79 C
critical (S5):           78 C
<not supported>
<polling disabled>
state:                   ok
temperature:             67 C
critical (S5):           72 C
--

As soon as I install Fedora Core 2 I'll tell you if the problem is
still there. But I know I have already tried a few 2.6-based fedora
kernels a few months ago and the problem was still there, then I
reverted to 2.4.
Comment 4 Dave Jones 2004-11-21 16:03:25 EST
Still a problem in latest kernels ?
Comment 5 Julien Olivier 2004-11-22 05:29:22 EST
No, it seems fixed now. You can close it, thanks.
Comment 6 Ravindra 2005-01-12 01:29:18 EST
hi i have read all above conversation about repeating keys. I have the
same problem after I upgrade from Redhat 8.0 to Fedora core 2, kernel
2.6 ofcourse. As said above, if turn acpi=off from grup.conf, the key
repeating problem disappears, but sound card is undetected. 
Could you please help me out...ASAP.
secondly could you add ravindrakrk@yahoo.com, so that i can get reply.
thanks

Note You need to log in before you can comment on or make changes to this bug.