Bug 74635 - Sticky keyboard keys (get stuck on autorepeat)
Sticky keyboard keys (get stuck on autorepeat)
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
: Triaged
: 74760 89702 (view as bug list)
Depends On:
Blocks: 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2002-09-27 21:51 EDT by berto
Modified: 2015-01-04 17:02 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-27 10:08:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description berto 2002-09-27 21:51:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020827

Description of problem:
After using a shortcut key to switch viewports in GNOME, the keyboard will
frequently, but not always, stop working.  To solve the problem, I've had to hit
a bunch of keys with the modifyer key I used for the shortcut until keyboard
operation resumes.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Setup shortcut keys to switch viewports with the windows key or the alt key (
i used win+1-6 or alt+1-6 to switch between 6 viewports in a 3x2 configuration ).

2. Switch viewports with the keystroke selected.  

3. Sometimes the keyboard will work normally, other times it will get stuck and
keys have to be hit randomly until it works again.
	

Actual Results:  the keyboard stops working

Expected Results:  keyboard should work normally after the keystroke.

Additional info:

Everything was working fine until i decided to install and try using Galeon (
galeon-1.2.5-6 ) for web browsing.  Additionally I started using Evolution (
evolution-1.0.8-7 ) at the same time; i was using the mozilla web browser + mail
client before.

After discovering the bug, I stopped using Galeon and Evolution to see if either
of those was the problem ( and even uninstalled Galeon ), but it has continued,
so I'm assumming that it was just coincidence.  

Around the same time I also upgraded my kernel to 2.4.18-14 ( from rev 11 ), but
I'm unsure how that would affect the keyboard in X.
Comment 1 Havoc Pennington 2002-09-27 22:04:07 EDT
When you say the keyboard has stopped working, which of the following work 
or don't work:

 - using the window manager shortcuts (such as your Alt+1, or Alt+Tab)
 - typing in a terminal window
 - typing in other applications
 - Ctrl+Alt+F1 to switch to a virtual console

Comment 2 berto 2002-09-28 01:25:30 EDT
The keyboard stops working as in typing in any application that takes normal
keyboard input.  I've tried typing in gnome-terminal, gaim, emacs ( GUI version
), evolution, xchat, and Galeon, but none of them work.  

Another interesting tidbit I forgot to mention is that when the keyboard does
continue to work, if there is an active window ready to take input in that
viewport, it will enter the value of the unmodified key.  For example, the
shortcut to my 1st viewport is winkey+1, if there is an active teminal window in
the viewport when i switch to it, the character '1' will be typed in the window.

Hope this helps a bit more.
Comment 3 berto 2002-09-28 01:37:48 EDT
Forgot to mention that other window manager shortcuts such as alt+tab and
switching to a virtual console with ctrl+alt+F1 still work fine.

I have also made sure that it's not my keyboard;  I checked that the connection
to the back of the computer is secure and that my keys are working properly. 
They all seem to work without a problem.  I would try a different keyboard, but
I don't have an extra one around ... : \

Hmm, another strange thing happened just now too.  I was holding down backspace
to get rid of a word and when I let go of the key, it kept backspacing for
another little bit before letting up.

Also in Galeon, when i hit ctrl+pageup/pagedown to switch between tabs, it kept
switching tabs spurratically, and when i hit ctrl+w to close a tab it sometimes
closes more than one.

It seems like the keyboard commands are 'sticking' somehow ... ?
Comment 4 Havoc Pennington 2002-09-28 09:53:59 EDT
Can you open Preferences->Accessibility and be sure all that stuff is unchecked?
Comment 5 berto 2002-09-28 13:15:41 EDT
I opened up the Accessibility dialog and the only thing that was checked was
"Beep when enabling/disabling keyboard accessibility features".  I have
unchecked that, and the problem continues.

If there are any config files you want me to attach, or a list of rpms
installed, let me know.  Thanks for all the help so far!
Comment 6 Havoc Pennington 2002-09-28 14:24:13 EDT
Hmm. I don't have a lot more ideas offhand; would be interesting to see if
upgrading to final released packages makes a difference.
Comment 7 berto 2002-10-02 18:18:09 EDT
I upgraded to the final release of 8.0 and the keyboard still occasionally gets
'stuck'.  I set the shortcuts to alt+1 - 6 for the 6 view ports.

I'm not sure what other details are relevant.
Comment 8 berto 2002-10-07 01:37:41 EDT
Just a quick note; I bought a new keyboard this weekend but am still getting
'sticky' keys.  I was hoping that would have solved it.  : \
Comment 9 berto 2002-11-04 17:51:17 EST
I'm not sure how related they are, or if that was the problem, but i compiled
and installed kernel 2.4.19 and my keyboard problems have gone away.  

I'm very happy.  : )

Thanks,
Roberto.
Comment 10 Havoc Pennington 2002-12-13 21:57:26 EST
I believe there's an upstream bug about this that may 
be enlightening, on http://bugzilla.gnome.org. Need to find 
said bug.

I've seen this problem occasionally also, but it's hard to reproduce.
Comment 11 Havoc Pennington 2003-01-06 19:06:12 EST
Not sure we have much chance of making progress on this bug, but 
keeping it open for now.
Comment 12 Tim Keitt 2003-01-14 14:51:03 EST
I am also seeing this bug. Seems like a race condition. My guess is that there
are some tricky timing issues at the driver level and that 2.8GHz is just a bit
too fast.
Comment 13 Havoc Pennington 2003-01-14 14:59:46 EST
For me this only happens on my Apple USB keyboard, not on my Sun USB keyboard.
What kinds of keyboard do people have?
Comment 14 Havoc Pennington 2003-01-14 16:50:03 EST
Probably same as https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=74760
Comment 15 Sven Neuhaus 2003-01-15 05:40:49 EST
Yes this sounds like a dupe. "get stuck on autorepeat" is a new issue not
mentioned in the other bug, however. I seem to have that problem, too... mostly
when deleting Mails in evolution, it sometimes deletes more than one when
pressing CTRL-D.
Could this be related to the "software" keyrepeat that is active with RH8? I
mean it looks like under X, the builtin keyboard controller keyrepeat is no
longer used, otherwise you couldn't set a minimal delay of smaller than 250ms
and repeats of more than 30keys/sec (great new feature btw.. I've always missed it!)
Comment 16 Havoc Pennington 2003-01-15 09:17:51 EST
*** Bug 74760 has been marked as a duplicate of this bug. ***
Comment 17 Havoc Pennington 2003-01-15 09:19:59 EST
Arjan - several people saying kernel upgrade fixed this on bug 74760
Comment 18 Sven Neuhaus 2003-01-15 10:02:34 EST
Havoc: I use a Happy Hacking Keyboard Lite (PS/2).

And upgrading to the latest official RH8 kernel (kernel-2.4.18-19.8.0) didn't
fix it. I don't want to upgrade to a rawhide 2.4.20 kernel on this production
machine.. 
Comment 19 Todd Allen 2003-01-17 13:38:01 EST
I believe the "get stuck on autorepeat" problem is the same as bug 66520.
Comment 20 aaron weber 2003-02-03 11:35:25 EST
This happens to me, but it seems to only happen with modified or special keys:
ctrl-t or ctrl-w will open or close between 1 and 3 tabs in galeon, for example,
or ctrl-alt-arrow will move me one to three workspaces, or Ctrl-C will kill one
or two applications in different places (quitting emacs, for example, also ends
up killing whatever is running in the terminal that gets focus next). But I
haven't seen it with regular letters.
Comment 21 aaron weber 2003-03-26 18:59:38 EST
Update: I see this bug with a variety of keystrokes, mostly in combination, and
mostly when the system is under moderate to high load. I am running a 500MHz
PIII, so it's not a "my system is too fast" problem. I have just upgraded to
kernel-2.4.18-27.8.0 and the issue is still there.
Comment 22 aaron weber 2003-07-08 11:45:34 EDT
This seems to have gone away after upgrading to a 2.4.20 kernel.
Comment 23 Julien Olivier 2003-10-17 05:03:02 EDT
I just wanted to tell you that I used to have this problem on my Fujitsu/Siemens
Amilo D laptop using stock Red Hat 9.

Sometimes, keys got stuck and I had to hit this key again to fix the problem. It
used to happen with any key by the way (not only modifiers). And I noticed it
mostly when using Evolution.

Now, I installed Fedora Core Test 3 and the problem seems fixed.

PS: I had filed this bug in bugzilla.redhat.com but I can't find it back :(
Comment 24 Julien Olivier 2003-10-27 06:55:00 EST
I have sad news...

Using fedora Core Test 3, I can reproduce this bug. But only if my laptop is
un-plugged. The thing is that, if my laptop is unplugged, it uses its battery
and runs more slowly. It seems then that, if the laptop runs more slowly, this
bug appears.

Now, I have also noticed something:

When I use my laptop plugged, I have a strange bug: when using a lot of CPU (for
example, running a 3D-accelerated game), my computer simply shuts down by
itself... I didn't have this bug in Redhat 9. But I had the sticky keys bug.
Now, if I un-plug my laptop, I don't have the auto-shutdown problem but I have
the sticky keys one.

Do you think those 2 bugs might be related ?

PS: my laptop is a Fujitsu/Siemens Amilo D with an ATI Radeon M6.
Comment 25 Julien Olivier 2003-10-27 09:34:03 EST
I have changed my laptop's BIOS setting to "smart throttle" power management. I
don't know what it's supposed to be, but now my laptop is slower, even when
plugged and the sticky keys bug is clearly back.

See https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=107937 for more info.
Comment 26 Julien Olivier 2003-10-27 10:46:49 EST
Another note: disabling ACPI (using acpi=off) makes the bug go away again.
Comment 27 Julien Olivier 2003-10-27 17:49:02 EST
*** Bug 89702 has been marked as a duplicate of this bug. ***
Comment 28 Julien Olivier 2003-11-01 18:55:42 EST
OK, after some investigation, I found out that the problem occurs when:
 - You have ACPI activated in your kernel (using acpi=on)
 - Whether you use acpid or not
 - The temperature of your CPU is too high

In my case, a "cat /proc/acpi/thermal_zone/THR1/trip_points" gives the
following:

critical (S5):           78 C

And the bug appears whenever the temperature reaches 79 C (according
to "cat /proc/acpi/thermal_zone/THR1/temperature")

I have tried to change the critical trip point to a higher temperature
but the problem still occurs at 79 C...

Does anyone have any idea about that ?
Comment 29 Dave Jones 2003-11-18 10:22:46 EST
Please open a new bug for the ACPI problem.
Comment 30 Julien Olivier 2003-11-18 11:11:02 EST
Done. It's bug #110332.
Comment 31 Mike A. Harris 2003-12-18 12:00:02 EST
If you are experiencing the problem reported in this bug report,
please read bug #76959 as it describes a similar problem.  I have
just added a patch to XFree86 which may fix that bug report, and
it's possible it may fix this one also.

If you find that it does fix the problem, please reassign this
bug to XFree86, and close as a duplicate of bug #76959.  Do the
same with any other similar bug reports you're aware of, if you
can confirm them as well.

TIA

Note You need to log in before you can comment on or make changes to this bug.