Bug 110342 - 'ccm load' doesn't pick up the classes12.jar
'ccm load' doesn't pick up the classes12.jar
Status: CLOSED RAWHIDE
Product: Red Hat Web Application Framework
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dennis Gregorovic
Jon Orris
:
: 110573 (view as bug list)
Depends On:
Blocks: 109665
  Show dependency treegraph
 
Reported: 2003-11-18 12:33 EST by Daniel Berrange
Modified: 2007-04-18 12:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-03 14:45:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2003-11-18 12:33:09 EST
Description of problem:

The stop & start scripts for servlet containers automatically pick up
the $ORACLE_HOME and stuff classes12.zip into the appropriate place
(IIRC, java.ext.dirs). The ccm-run script, however, doesn't seem to do
the same. So when running 'ccm load' it is unable to find the Oracle
JDBC driver:

Exception in thread "main"
com.arsdigita.util.UncheckedWrapperException (root cause:
java.lang.ClassNotFoundException: oracle.jdbc.driver.OracleDriver)
        at com.arsdigita.util.Classes.loadClass(Classes.java:50)
        at
com.arsdigita.util.jdbc.Connections.acquire(Connections.java:64)
        at com.arsdigita.packaging.Load.run(Load.java:232)
        at com.arsdigita.packaging.MasterTool.main(MasterTool.java:100)
Root cause: java.lang.ClassNotFoundException:
oracle.jdbc.driver.OracleDriver
        at java.net.URLClassLoader.findClass(URLClassLoader.java:240)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:514)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:441)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:446)
        at java.lang.Class.forName1(Native Method)
        at java.lang.Class.forName(Class.java:142)
        at com.arsdigita.util.Classes.loadClass(Classes.java:48)
        at
com.arsdigita.util.jdbc.Connections.acquire(Connections.java:64)
        at com.arsdigita.packaging.Load.run(Load.java:232)
        at com.arsdigita.packaging.MasterTool.main(MasterTool.java:100)
[arturo@staging01 aplaws-camden]$ echo $ORACLE_HOME 
/opt/oracle/product/9.2.0
[arturo@staging01 aplaws-camden]$ ls $ORACLE_HOME/jdbc/lib/classes12.jar 
/opt/oracle/product/9.2.0/jdbc/lib/classes12.jar
[arturo@staging01 aplaws-camden]$ 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Berrange 2003-11-21 09:54:50 EST
*** Bug 110573 has been marked as a duplicate of this bug. ***
Comment 2 Dennis Gregorovic 2003-11-21 11:13:00 EST
@38203
Comment 3 Jon Orris 2003-12-01 11:02:34 EST
Marking QA Ready.
Dan, can you comment on whether the solution is OK, as you opened the
ticket?
Comment 4 Daniel Berrange 2003-12-01 11:21:02 EST
Yeah, looks ok to me.

Note You need to log in before you can comment on or make changes to this bug.