Bug 110573 - ccm-profile does not export CLASSPATH
ccm-profile does not export CLASSPATH
Status: CLOSED DUPLICATE of bug 110342
Product: Red Hat Web Application Framework
Classification: Retired
Component: dev environment (Show other bugs)
6.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Jon Orris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-21 09:46 EST by Steve Etherington
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Etherington 2003-11-21 09:46:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET 
CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
ccm load-aplaws .... fails because it it unable to find the jdbc 
driver. The CLASSPATH variable contains the path for the appropriate 
classes12.zip but javac can't find it. If I run 

#export CLASSPATH 

then everything runs ok.

Version-Release number of selected component (if applicable):
6.1

How reproducible:
Always

Steps to Reproduce:
1. create a new login
2. add to ccm
3. create a project
4. run ccm-profile <prject-name>
5. ccm load-aplaws -- ....

    

Actual Results:  fails with error reporting 
oracle.jdbc.driver.OracleDriver not found

Expected Results:  installs correctly

Additional info:

I'm running redhat 8 with bash shell.
Comment 1 Daniel Berrange 2003-11-21 09:54:47 EST

*** This bug has been marked as a duplicate of 110342 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:06 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.