Bug 110390 - Nautilus won't "Move to Trash" in some cases
Nautilus won't "Move to Trash" in some cases
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
: 116290 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-18 18:37 EST by Yeroc
Modified: 2007-04-18 12:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-11 05:44:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yeroc 2003-11-18 18:37:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031031

Description of problem:
I'm attempting to delete a file using nautilus by right-clicking on
the file and selecting "Move to Trash".  Nothing happens.  I've
verified the permissions and ownership of the file and everything is
fine.  I am able to delete the files in question via a bash shell session.

I've noticed that I *can* delete files that reside in my home
directory using nautilus.  Note that my home directory is mounted over
nfs.  The files that nautilus refuses to delete always appear to be
files located on local file systems.

I assume my "Trash" is located in my home directory.  Does nautilus
have a bug in it where it can't delete files when the "Trash" lives on
different file system and/or on nfs?!?


Version-Release number of selected component (if applicable):
nautilus-2.2.1-5

How reproducible:
Always

Steps to Reproduce:
[See my description above.  I believe this only happens if your
"Trash" is located on a filesystem separate from the file(s) you are
attempting to delete or possibly it's isolated to the case where the
"Trash" lives on an nfs filesystem.]
    

Actual Results:  Nothing happens.

Expected Results:  File should have been moved to the Trash.
Comment 1 Alexander Larsson 2004-02-06 11:15:36 EST
Do you get a dialog that says the file couldn't be moved to trash?

(The trash system is more complicated than just one directory, it will
try to find a trash on that partition, and if there is none it should
open a dialog asking if you want to delete the file instead.)
Comment 2 Yeroc 2004-02-10 13:24:05 EST
I get no output whatsoever.  No dialog box.  No error message.  Nothing.
Comment 3 Alexander Larsson 2004-02-11 05:44:50 EST
This is upstream as http://bugzilla.gnome.org/show_bug.cgi?id=128139
Comment 4 Yeroc 2004-02-11 10:52:12 EST
Indeed, I was the one that filed that bug hoping that between Gnome &
RedHat someone would look into it and fix it... Is it RedHat's policy
to close a bug if you find it logged elsewhere even if there's no fix?
Comment 5 Alexander Larsson 2004-02-12 05:55:03 EST
Unless its a stop-ship bug that we *need* to track for a release, a
non-packaging bug makes much more sense upstream where the actual
developers of the app and other interested parties can see it. 

In this particular case, I'm also the primary owner of the bug both
upstream and at redhat. So, doubling my bugzilla workload by storing
the bug in two places certainly isn't helping me to fix the bug,
neither is having some bugs in the rh bugzilla and some others in the
gnome bugzilla.

I mean, why should this particular bug be in redhat bugzilla, and not
the 800 other open nautilus bugs in the gnome bugzilla? Or do you
think we should import all of those into the redhat bugzilla? Bugzilla
is a way for developers to track bugs so they can do their work more
efficiently, not a way for people to make developers work on their
favourite bug.
Comment 6 Alexander Larsson 2004-02-25 03:59:01 EST
*** Bug 116290 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.