Bug 1104015 - [RFE] - fork/copy from previous version with source and translation
Summary: [RFE] - fork/copy from previous version with source and translation
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Component-Logic (Show other bugs)
(Show other bugs)
Version: development
Hardware: Unspecified Linux
unspecified
medium
Target Milestone: ---
: 3.5
Assignee: Alex Eng
QA Contact: Damian Jansen
URL:
Whiteboard:
Keywords:
: 895786 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-03 06:02 UTC by Patrick Huang
Modified: 2015-03-30 23:22 UTC (History)
7 users (show)

Fixed In Version: Commit d41d8cd98f00b204e9800998ecf8427e
Doc Type: Bug Fix
Doc Text:
Story Points: 8
Clone Of:
Environment:
Last Closed: 2015-01-26 23:28:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Patrick Huang 2014-06-03 06:02:22 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.63 Safari/537.31
Build Identifier: 

As a project maintainer, I will like to create a new version that is based on previous version, so that the new version will have most of the translation already in place. When I push new source documents, it will hopefully have most of the translation filled. This will reduce the amount of text flows that needs copyTrans

Reproducible: Always

Comment 2 David Mason 2014-06-04 01:49:44 UTC
From planning meeting:

 - selector on version create page to choose starting content
  - options: empty, each other version
  - this element should be prominent (possible modal?)
 - copies all source documents, their translations and history
  - copy is done as a background task of some kind
  - raw documents also need to be copied since they are mutable
 - show progress indicator on version page until copy has completed
 - while copy is occurring:
  - source document upload is prevented
  - translation is prevented
  - can probably force the version to READONLY until the copy is finished (make sure REST endpoint can't push to READONLY versions)
 - 'copy' button on existing versions that will open the version create dialog with the version selected as the starting content
 - copy can be canceled. Canceling will stop the copy, leaving any already-copied documents and translations in the new version.

 - NOT including copying into a pre-existing version yet (that may be an enhancement later).
 - NOT including any REST hooks or client interface for this functionality

Comment 4 Alex Eng 2014-07-04 05:59:53 UTC
Pull request:
https://github.com/zanata/zanata-server/pull/525

Comment 5 Ding-Yi Chen 2014-08-12 00:06:15 UTC
VERIFIED by Damian:
See https://github.com/zanata/zanata-server/pull/525

Comment 6 Michelle Kim 2015-03-30 23:22:35 UTC
*** Bug 895786 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.