Bug 895786 - RFE: As a project maintainer, I want to clone a project version, with or without source/target documents
RFE: As a project maintainer, I want to clone a project version, with or with...
Status: CLOSED DUPLICATE of bug 1104015
Product: Zanata
Classification: Community
Component: Component-Logic (Show other bugs)
development
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Isaac Rooskov
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-15 20:46 EST by Sean Flanigan
Modified: 2015-08-06 01:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-30 19:22:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Flanigan 2013-01-15 20:46:47 EST
Description of problem:
As a project maintainer, I want to clone a project version, with or without source/target documents.

When branching for a new release, some project maintainers have to pull down the PO files from the old version in Zanata, then push POT and PO to the new version in Zanata.  For large projects, this can take a very long time. Most of this could be handled by CopyTrans instead, but CopyTrans does not preserve file-level credits, and is probably much slower than a straight clone.
Comment 1 Michelle Kim 2015-03-30 19:22:35 EDT
We already implemented this feature - CopyVersion Bug #1104015

*** This bug has been marked as a duplicate of bug 1104015 ***

Note You need to log in before you can comment on or make changes to this bug.