Bug 1104088 - Failed loading plugin: copr / ImportError: No module named requests
Failed loading plugin: copr / ImportError: No module named requests
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
20
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
:
: 1114594 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-06-03 05:17 EDT by Michael Monreal
Modified: 2015-01-30 05:07 EST (History)
7 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.1.1-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-08 22:30:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Monreal 2014-06-03 05:17:01 EDT
Description of problem: (split out from #1094396)
Failed loading plugin: copr

From the log:

Jun 03 11:09:26 ERROR Failed loading plugin: copr
Jun 03 11:09:26 SUBDEBUG 
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/dnf/plugin.py", line 119, in import_modules
    module = importlib.import_module(name)
  File "/usr/lib64/python2.7/importlib/__init__.py", line 37, in import_module
    __import__(name)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/copr.py", line 29, in <module>
    import requests
ImportError: No module named requests

Version-Release number of selected component (if applicable):
dnf-plugins-core-0.0.8-2.fc20.noarch

How reproducible: 100%

Steps to Reproduce:
1. dnf update

Additional info:
On my system, the "python-requests" package was not installed. It should be in the requires of dnf-plugins-core. After adding the package manually, the plugin works again.
Comment 1 Ales Kozumplik 2014-06-04 03:22:56 EDT
Moving to Mirek.

Mirek, I see this as further evidence that copr should be split out of the core plugins since by adding this dependency all users that need one of the other core plugins but not the copr plugin will have to have installed python-request.
Comment 2 Miroslav Suchý 2014-06-05 03:38:32 EDT
Fixed in:
* e87fab2  build: add python-requests to requires (RHBZ: 1104088)
Comment 3 Ales Kozumplik 2014-06-30 09:15:40 EDT
*** Bug 1114594 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2014-07-07 05:11:52 EDT
dnf-plugins-core-0.1.1-2.fc20, dnf-0.5.3-1.fc20, hawkey-0.4.17-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.5.3-1.fc20,hawkey-0.4.17-1.fc20,dnf-plugins-core-0.1.1-2.fc20
Comment 5 Fedora Update System 2014-07-07 21:04:14 EDT
Package dnf-plugins-core-0.1.1-2.fc20, dnf-0.5.3-1.fc20, hawkey-0.4.17-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.1.1-2.fc20 dnf-0.5.3-1.fc20 hawkey-0.4.17-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8167/dnf-0.5.3-1.fc20,hawkey-0.4.17-1.fc20,dnf-plugins-core-0.1.1-2.fc20
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2014-07-08 22:30:07 EDT
dnf-plugins-core-0.1.1-2.fc20, dnf-0.5.3-1.fc20, hawkey-0.4.17-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Andrew Travneff 2015-01-30 05:07:21 EST
dnf-3 has the same with python3-requests

Note You need to log in before you can comment on or make changes to this bug.