Bug 1114594 - Failed loading plugin: copr (due to missing python-requests)
Summary: Failed loading plugin: copr (due to missing python-requests)
Keywords:
Status: CLOSED DUPLICATE of bug 1104088
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-30 13:05 UTC by Miro Hrončok
Modified: 2014-06-30 13:15 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-30 13:15:40 UTC


Attachments (Terms of Use)

Description Miro Hrončok 2014-06-30 13:05:03 UTC
Description of problem:
copr plugin fails to load

Version-Release number of selected component (if applicable):
dnf-0.5.2-1.fc20.noarch
dnf-plugins-core-0.1.0-2.fc20.noarch

How reproducible:
On fresh Fedora 20 install 

Steps to Reproduce:
1. Install F20
2. Install dnf and dnf-plugins-core
3. Run dnf copr

Actual results:
# LANG=C dnf -v copr
Config time: 0.006
cachedir: /var/cache/dnf/x86_64/20
Failed loading plugin: copr
Loaded plugins: debuginfo-install, download, builddep, generate_completion_cache, noroot, kickstart, Query
initialized DebuginfoInstall plugin
initialized BuildDep plugin
initialized Noroot plugin
Initialized Query plugin
dnf version: 0.5.2
No such command: copr. Please use /bin/dnf --help
Cleaning up.


Expected results:
# LANG=C dnf -v copr
Config time: 0.006
cachedir: /var/cache/dnf/x86_64/20
Loaded plugins: debuginfo-install, download, builddep, generate_completion_cache, noroot, kickstart, copr, playground, Query
initialized DebuginfoInstall plugin
initialized BuildDep plugin
initialized Noroot plugin
initialized Copr plugin
initialized Playground plugin
Initialized Query plugin
dnf version: 0.5.2
Error: exactly two additional parameters to copr command are required
 Mini usage:

copr 
  enable name/project [chroot]
  disable name/project
  list name
  search project

  Examples:
  copr enable rhscl/perl516 epel-6-x86_64
  copr enable ignatenkobrain/ocltoys
  copr disable rhscl/perl516
  copr list ignatenkobrain
  copr search tests
    

Interact with Copr repositories.
Error: exactly two additional parameters to copr command are required
Cleaning up.

Additional info:
copr plugin needs python-requests, while dnf-plugins-core does not require it

Permission to fix this?

Comment 1 Tim Lauridsen 2014-06-30 13:14:18 UTC
Duplicate of 

https://bugzilla.redhat.com/show_bug.cgi?id=1104088

Comment 2 Ales Kozumplik 2014-06-30 13:15:40 UTC

*** This bug has been marked as a duplicate of bug 1104088 ***


Note You need to log in before you can comment on or make changes to this bug.