Bug 110433 - Kudzu Crashes with Zaurus plugged in
Kudzu Crashes with Zaurus plugged in
Status: CLOSED DUPLICATE of bug 106332
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-19 10:59 EST by Aric
Modified: 2014-03-16 22:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Strace output when I run kudzu that shows the segfault. (41.77 KB, text/plain)
2003-11-21 14:10 EST, Aric
no flags Details
GDB Output of Segfault (5.64 KB, text/plain)
2003-12-03 20:51 EST, Aric
no flags Details

  None (edit)
Description Aric 2003-11-19 10:59:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
When I boot Fedore Core 1.0 with my Zaurus plugged in and turned on,
Kudzu crashes.  I see a FAILED message for it, and above it is shown a
segfault message.

In order for the Zaurus to be recognized and work, you have to put
this into /etc/hotplug/blacklist:
CDCEther
acm

A friend of mine has also reported that redhat-config-network crashes
on startup when the Zaurus is plugged in and on.

Could be related if they depend on same libraries.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. With computer off, plug in and turn on Zaurus
2. Boot computer
3. The graphical boot screen switches to the detailed mode, and you
can see that kudzu has crashed with a segfault.
    

Additional info:
Comment 1 Bill Nottingham 2003-11-19 12:19:02 EST
Does it crash post-boot as well?

Can you install the debuginfo and get a traceback?
Comment 2 Aric 2003-11-21 14:10:34 EST
Created attachment 96123 [details]
Strace output when I run kudzu that shows the segfault.

I haven't had a chance to find and install debuginfo yet, but here is the
strace output when kudzu crashes.  Also, yes, it does crash post-boot when I
run from the commandline--thus the strace.
Comment 3 Aric 2003-12-03 20:51:48 EST
Created attachment 96329 [details]
GDB Output of Segfault

I was not able to find debuginfo, so I ran kudzu with gdb. This attached file
contains that. I also found that running hwbrowser crashes as well. I ran
python with DeviceList.py in GDB, and the second listing in this file is from
that.
Comment 4 Bill Nottingham 2004-02-04 01:16:01 EST

*** This bug has been marked as a duplicate of 106332 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:00:04 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.