Bug 1104603 - libgit2 tests fail on BE
libgit2 tests fail on BE
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libgit2 (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Veeti Paananen
Fedora Extras Quality Assurance
:
: 1105552 (view as bug list)
Depends On:
Blocks: ZedoraTracker PPCTracker
  Show dependency treegraph
 
Reported: 2014-06-04 06:24 EDT by Jakub Čajka
Modified: 2015-03-18 16:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-18 16:01:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch fixing tests on BE (4.06 KB, patch)
2014-06-11 04:20 EDT, Jakub Čajka
no flags Details | Diff

  None (edit)
Description Jakub Čajka 2014-06-04 06:24:20 EDT
Description of problem:
tests fail on BE machines

Version-Release number of selected component (if applicable):
libgit2-0.20.0-3.fc21

How reproducible:
Always

Steps to Reproduce:
1. build package on BE machine

Actual results:
build fails

Expected results:
build passes

Additional info:
I'm looking in to it.
Comment 1 Jakub Čajka 2014-06-04 06:50:22 EDT
Failed tests:

  On s390:

1:   1) Failure:
1: threads::refdb::edit_while_iterate [/builddir/build/BUILD/libgit2-0.20.0/tests/threads/refdb.c:132]
1:   Function call failed: git_reference_delete(ref)
1:   error -1 - <no message>

  On ppc64/s390x:

1:   1) Failure:
1: blame::buffer::added_line [/builddir/build/BUILD/libgit2-0.20.0/tests/blame/blame_helpers.c:37]
1:   hunk->final_start_line_number != start_line
1:   7 != 6
1: 
1:   2) Failure:
1: blame::buffer::deleted_line [/builddir/build/BUILD/libgit2-0.20.0/tests/blame/blame_helpers.c:37]
1:   hunk->final_start_line_number != start_line
1:   5 != 6
1: 
1:   3) Failure:
1: blame::buffer::add_splits_hunk [/builddir/build/BUILD/libgit2-0.20.0/tests/blame/blame_helpers.c:37]
1:   hunk->final_start_line_number != start_line
1:   7 != 6
1: 
1:   4) Failure:
1: blame::buffer::delete_crosses_hunk_boundary [/builddir/build/BUILD/libgit2-0.20.0/tests/blame/blame_helpers.c:37]
1:   hunk->final_start_line_number != start_line
1:   65535 != 6
1: 
1:   5) Failure:
1: blame::buffer::replace_line [/builddir/build/BUILD/libgit2-0.20.0/tests/blame/blame_helpers.c:43]
1:   hunk->lines_in_hunk != len
1:   5 != 1
1: 
1:   6) Failure:
1: blame::getters::byline [/builddir/build/BUILD/libgit2-0.20.0/tests/blame/getters.c:51]
1:   Expression is not true: h
1: 
1:   7) Failure:
1: merge::workdir::renames::renames [/builddir/build/BUILD/libgit2-0.20.0/tests/merge/workdir/renames.c:64]
1:   Expression is not true: merge_test_workdir(repo, merge_index_entries, 24)
1: 
1:   8) Failure:
1: merge::workdir::renames::ours [/builddir/build/BUILD/libgit2-0.20.0/tests/merge/workdir/renames.c:105]
1:   Expression is not true: merge_test_workdir(repo, merge_index_entries, 20)
1: 
1:   9) Failure:
1: merge::workdir::renames::similar [/builddir/build/BUILD/libgit2-0.20.0/tests/merge/workdir/renames.c:152]
1:   Expression is not true: merge_test_workdir(repo, merge_index_entries, 24)
1:
Comment 2 Dan Horák 2014-06-06 07:49:16 EDT
*** Bug 1105552 has been marked as a duplicate of this bug. ***
Comment 3 Jakub Čajka 2014-06-11 04:20:34 EDT
Created attachment 907531 [details]
Patch fixing tests on BE

I have managed to fix nearly all test failures(patch in attachment), except for s390 failure. It seems that it's cause by some sort thread related problem (race condition?). I was unable to reproduce it(ever since it builds successfully/test passes). Rest was type cast related. Patched package builds successfully on all platforms. Please note patch changes public declaration of two functions.
Comment 4 Veeti Paananen 2014-06-11 04:34:11 EDT
Have you reported this upstream (https://github.com/libgit2/libgit2)? Is this still an issue with the development version and/or 0.21.0 release candidate?
Comment 5 Jakub Čajka 2014-06-11 05:15:54 EDT
Yes I have.It is failing.Just tried development, blame isn't failing(that's interesting), merge test fails same way...

My patch fixes most of test failures in development except for this(new in development)

1) Failure:
1: odb::foreach::files_in_objects_dir [/home/jcajka/fedora/libgit2/libgit2/tests/odb/foreach.c:101]
1:   47 + 1640 != nobj
1:   1687 != 0

I will look in to it.
Comment 6 Jaroslav Reznik 2015-03-03 10:52:08 EST
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22
Comment 7 Veeti Paananen 2015-03-14 07:24:33 EDT
Hi,

Is this still an issue on 0.21.5 and/or 0.22.1?
Comment 8 Jakub Čajka 2015-03-16 03:42:48 EDT
Hello, 

libgit2 builds fine in both versions and tests pass. Tests could be enabled.

Thanks!
Comment 9 Veeti Paananen 2015-03-18 16:01:01 EDT
Great, thanks.

Note You need to log in before you can comment on or make changes to this bug.