Bug 1105552 - FTBFS: unit tests fail on 64bit bigendian machines (ppc64, s390x)
Summary: FTBFS: unit tests fail on 64bit bigendian machines (ppc64, s390x)
Status: CLOSED DUPLICATE of bug 1104603
Alias: None
Product: Fedora
Classification: Fedora
Component: libgit2
Version: rawhide
Hardware: ppc64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Veeti Paananen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2014-06-06 11:40 UTC by Karsten Hopp
Modified: 2014-06-06 11:49 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-06-06 11:49:16 UTC


Attachments (Terms of Use)

Description Karsten Hopp 2014-06-06 11:40:36 UTC
Description of problem:
1:   1) Failure:
1: blame::buffer::added_line [/builddir/build/BUILD/libgit2-0.20.0/tests/blame/blame_helpers.c:37]
1:   hunk->final_start_line_number != start_line
1:   7 != 6
1: 
1:   2) Failure:
1: blame::buffer::deleted_line [/builddir/build/BUILD/libgit2-0.20.0/tests/blame/blame_helpers.c:37]
1:   hunk->final_start_line_number != start_line
1:   5 != 6
1: 
1:   3) Failure:
1: blame::buffer::add_splits_hunk [/builddir/build/BUILD/libgit2-0.20.0/tests/blame/blame_helpers.c:37]
1:   hunk->final_start_line_number != start_line
1:   7 != 6
1: 
1:   4) Failure:
1: blame::buffer::delete_crosses_hunk_boundary [/builddir/build/BUILD/libgit2-0.20.0/tests/blame/blame_helpers.c:37]
1:   hunk->final_start_line_number != start_line
1:   65535 != 6
1: 
1:   5) Failure:
1: blame::buffer::replace_line [/builddir/build/BUILD/libgit2-0.20.0/tests/blame/blame_helpers.c:43]
1:   hunk->lines_in_hunk != len
1:   5 != 1
1: 
1:   6) Failure:
1: blame::getters::byline [/builddir/build/BUILD/libgit2-0.20.0/tests/blame/getters.c:51]
1:   Expression is not true: h
1: 
1:   7) Failure:
1: merge::workdir::renames::renames [/builddir/build/BUILD/libgit2-0.20.0/tests/merge/workdir/renames.c:64]
1:   Expression is not true: merge_test_workdir(repo, merge_index_entries, 24)
1: 
1:   8) Failure:
1: merge::workdir::renames::ours [/builddir/build/BUILD/libgit2-0.20.0/tests/merge/workdir/renames.c:105]
1:   Expression is not true: merge_test_workdir(repo, merge_index_entries, 20)
1: 
1:   9) Failure:
1: merge::workdir::renames::similar [/builddir/build/BUILD/libgit2-0.20.0/tests/merge/workdir/renames.c:152]
1:   Expression is not true: merge_test_workdir(repo, merge_index_entries, 24)
1: 
1/1 Test #1: libgit2_clar .....................***Failed   19.58 sec
0% tests passed, 1 tests failed out of 1
Total Test time (real) =  19.59 sec

Version-Release number of selected component (if applicable):
libgit2-0.20.0-2.fc21

How reproducible:
always

Steps to Reproduce:
1. ppc-koji build --scratch f21 libgit2-0.20.0-2.fc21.src.rpm
2.
3.

Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1880201
http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=1425147

Expected results:


Additional info:
-3 fails, too

Comment 1 Dan Horák 2014-06-06 11:49:16 UTC

*** This bug has been marked as a duplicate of bug 1104603 ***


Note You need to log in before you can comment on or make changes to this bug.