Bug 11047 - Openldap logging info lost
Summary: Openldap logging info lost
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openldap   
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
: 14509 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-25 21:33 UTC by mgawdun
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-31 21:52:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mgawdun 2000-04-25 21:33:58 UTC
Openldap is configured to send its logging information to the local4 log
selector.  Although logging is turned off by default, if it is turned on
syslog discards it.

To reproduce:
- add the line "loglevel 4095" to /etc/openldap/slapd.conf
- restart slapd
- begin a futile hunt for slapd logging information (optional)

Fix:
- append "local4.*   /var/log/ldap" to /etc/syslogd.
- configure logrotate to rotate above file

Comment 1 Bill Nottingham 2000-06-11 19:26:14 UTC
No, openldap should be logging someplace else sane.

Comment 2 Nalin Dahyabhai 2000-07-31 21:52:05 UTC
*** Bug 14509 has been marked as a duplicate of this bug. ***

Comment 3 Nalin Dahyabhai 2000-08-01 15:59:44 UTC
This should be fixed in openldap-1.2.11-10, where everything uses the LOG_DAEMON
facility by default.  Please reopen this bug ID if you find that this is not the
case.


Note You need to log in before you can comment on or make changes to this bug.