Bug 11048 - ping performs DNS lookups too often
Summary: ping performs DNS lookups too often
Status: CLOSED DUPLICATE of bug 10436
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: iputils   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-25 22:25 UTC by Adam Spiers
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-07 23:12:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adam Spiers 2000-04-25 22:25:28 UTC
Unless you disable DNS lookups altogether with the -n option, ping performs
a DNS lookup every time it sends an ICMP echo.  This is distinctly
anti-social behaviour, especially considering that the only reason it does
a DNS lookup is to make the output prettier.

This behaviour doesn't seem to occur with Redhat 6.0 and 6.1, presumably
because their ping comes from netkit-base rather than from iputils.

For reference, the maintainer of iputils seems to be
<kuznet@ms2.inr.ac.ru>, so I guess he should be contacted about this.

Comment 1 Neal Nuckolls 2000-05-02 18:03:59 UTC
No kidding.  If I give a numeric IP address to ping
I don't expect it to request and require DNS reverse
IPaddr-to-name entries to work.  Geez.  I just wasted
an hour trying to figure out what was introducing a large
random number of seconds delay when I did "ping 10.100.58.140"
and didn't use the "-n" option.  I've been using ping for
20 years and never had to use the "-n" option for
this basic diagnostic tool to work before.
Please FIX.  thanks.

nn@broadcom.com

Comment 2 bcboy 2000-05-07 23:12:59 UTC
An hour? I just lost five days to this "feature". DNS at my
work changed without notice, and I've been fighting ever since
trying to figure out why *all* my connectivity just stopped
working. tcpdump didn't turn up the dns queries, or I might
have noted it sooner.

Comment 3 Tim Waugh 2000-06-14 17:20:38 UTC

*** This bug has been marked as a duplicate of 10436 ***


Note You need to log in before you can comment on or make changes to this bug.