Bug 10436 - Funnies with ping and bogus nameservers at resolv.conf
Summary: Funnies with ping and bogus nameservers at resolv.conf
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: iputils (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Keywords:
: 10659 11048 11700 16138 (view as bug list)
Depends On:
Blocks: 11313
TreeView+ depends on / blocked
 
Reported: 2000-03-30 11:15 UTC by kauppi
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-31 16:32:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description kauppi 2000-03-30 11:15:37 UTC
/etc/resolv.conf:
search somedomain.com
nameserver 1.2.3.4 (Some bogus address where bind isn't running)

eth0 is configured as 192.168.0.2/24, default gw 192.168.0.1

ping 192.168.0.1 reports no replies or each reply is delayed by 4 seconds
(first like 2 ms, next 4030, next 8030 etc) even though tcpdump shows
normal operation (echo request and echo reply right after request). ping -n
192.168.0.1 works normally and reports correct times.

Tested on i386 platform, iputils-20000121-2

Comment 1 Tim Waugh 2000-03-31 16:32:59 UTC
This is as documented in the man page.  You've always needed to specify -n for
numeric output, modulo a bug in what the default was that is fixed in this
release.

(But yes, I preferred the old behaviour too.)

Comment 2 Tim Waugh 2000-06-14 17:19:31 UTC
*** Bug 10659 has been marked as a duplicate of this bug. ***

Comment 3 Tim Waugh 2000-06-14 17:20:37 UTC
*** Bug 11048 has been marked as a duplicate of this bug. ***

Comment 4 Tim Waugh 2000-06-14 17:21:09 UTC
*** Bug 11700 has been marked as a duplicate of this bug. ***

Comment 5 Bill Nottingham 2000-08-14 05:11:32 UTC
*** Bug 16138 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.