Bug 1105082 - DHT : - two directories has same gfid
Summary: DHT : - two directories has same gfid
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: Nagaprasad Sathyanarayana
QA Contact:
URL:
Whiteboard:
Depends On: 1092510 1118780 1139172
Blocks: 1143960
TreeView+ depends on / blocked
 
Reported: 2014-06-05 10:45 UTC by Raghavendra G
Modified: 2018-02-23 09:52 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1092510
: 1144485 (view as bug list)
Environment:
Last Closed: 2015-05-14 17:25:52 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2014-06-07 19:39:24 UTC
REVIEW: http://review.gluster.org/8008 (storage/posix: Treat mkdir on an existing gfid as rename.) posted (#1) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 2 Anand Avati 2014-09-14 18:58:32 UTC
REVIEW: http://review.gluster.org/8008 (storage/posix: Log when mkdir is on an existing gfid but non-existent path.) posted (#2) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 3 Anand Avati 2014-09-17 06:39:18 UTC
REVIEW: http://review.gluster.org/8008 (storage/posix: Log when mkdir is on an existing gfid but non-existent path.) posted (#3) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 4 Anand Avati 2014-09-18 11:11:07 UTC
REVIEW: http://review.gluster.org/8008 (storage/posix: Log when mkdir is on an existing gfid but non-existent path.) posted (#4) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 5 Anand Avati 2014-09-18 11:49:14 UTC
REVIEW: http://review.gluster.org/8008 (storage/posix: Log when mkdir is on an existing gfid but non-existent path.) posted (#5) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 6 Anand Avati 2014-09-18 17:16:04 UTC
COMMIT: http://review.gluster.org/8008 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 1e1b709a4b438dfa768fd4c645e081ede06e7e14
Author: Raghavendra G <rgowdapp@redhat.com>
Date:   Sun Jun 8 00:46:29 2014 +0530

    storage/posix: Log when mkdir is on an existing gfid but non-existent
    path.
    
    consider following steps on a distribute volume
    
    1. rename (src, dst) on hashed subvolume
    2. snapshot taken
    3. restore snapshots and do stat on src and dst
    
    Now, we end up with two directories src and dst having same gfid,
    because of distribute creating directories on non-existent subvolumes
    as part of directory healing.
    
    This can happen even with race between rename and directory healing in
    dht-lookup. This can lead to undefined behaviour while accessing any
    of both directories. Hence, we are logging paths of both
    directories, so that a sysadmin can take some corrective action when
    (s)he sees this log. One of the corrective action can be to copy
    contents of both directories from backend into a new directory and
    delete both directories.
    
    Since effort involved to fix this issue is non-trivial, giving this
    workaround till we come up with a fix.
    
    Change-Id: I38f4520e6787ee33180a9cd1bf2f36f46daea1ea
    BUG: 1105082
    Signed-off-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-on: http://review.gluster.org/8008
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Tested-by: Vijay Bellur <vbellur@redhat.com>

Comment 7 Niels de Vos 2015-05-14 17:25:52 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 8 Niels de Vos 2015-05-14 17:35:27 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 9 Niels de Vos 2015-05-14 17:37:49 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 10 Niels de Vos 2015-05-14 17:42:18 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.