Bug 1139172 - DHT + SNAPSHOT :- fop (which involves more than one brick )and snapshot race might result in inconsistent state of volume after snapshot restore
Summary: DHT + SNAPSHOT :- fop (which involves more than one brick )and snapshot race...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: distribute
Version: rhgs-3.0
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Nithya Balachandran
QA Contact: storage-qa-internal@redhat.com
URL:
Whiteboard: dht-snapshot
: 1118780 (view as bug list)
Depends On:
Blocks: 1087818 1105082 1118779 1252244 1324381
TreeView+ depends on / blocked
 
Reported: 2014-09-08 10:00 UTC by Rachana Patel
Modified: 2018-04-16 18:01 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-16 18:01:27 UTC


Attachments (Terms of Use)

Description Rachana Patel 2014-09-08 10:00:31 UTC
Description of problem:
=======================
fop (which involves more than one brick )and snapshot creation race might result in inconsistent state of volume after snapshot restore


Version-Release number of selected component (if applicable):
=============================================================
3.6.0.28-1.el6rhs.x86_64



How reproducible:
=================
always


Steps to Reproduce:
===================
If snapshot creation and fop (mkdir, rmdir, rename etc. - fop  which involves more than one brick to complete that operation ) is executed same time then on restoring that snap volume might have in-consistence state.

e.g
dir1 is hasing to sub-volume S0 and
'mkdir dir1' and snapshot creation is executed at same time.
In this case one possibility is:-

time    S0	S1	S2
t0

t1	 snap		snap

t2	dir1

t3  	dir1	dir1	dir1	

t4		snap


on restoring this snap at time tr
time    S0	S1	S2
tr		dir1


Only S1 sub-volume will have Directory and it will not be healed by lookup as Directory is present on only non-hashed sub-volume.



Additional info:
================
This is true for other operations also, creating this bug to track all such possibilities of fop and snapshot race.

Comment 6 Nithya Balachandran 2018-02-23 09:52:19 UTC
*** Bug 1118780 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.