Bug 1105624 - Guest agent not configured for Autostart
Summary: Guest agent not configured for Autostart
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-guest-agent
Version: 3.5
Hardware: Unspecified
OS: Windows
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: Vinzenz Feenstra [evilissimo]
QA Contact: Jiri Belka
URL:
Whiteboard: integration
Depends On: 1119642
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-06 14:39 UTC by Bob Doolittle
Modified: 2014-10-17 12:40 UTC (History)
8 users (show)

Fixed In Version: ovirt-guest-tools-3.5-2.iso
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:40:07 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Bob Doolittle 2014-06-06 14:39:07 UTC
Description of problem:

Running Windows Server 2008 R2 Enterprise

After installing ovirt-guest-tools-3.5-1.iso, service came up as expected.
Upon reboot, however it did not.

Running services.msc, I see that OVirt Guest Agent Service has "Startup Type" of "Manual".

After changing this to "Automatic", the service starts automatically upon reboot.

Version-Release number of selected component (if applicable):

3.5-1 alpha

Steps to Reproduce:
1. Mount CD
2. Run ovirt-guest-tools-3.5-1.exe in VM
3. Reboot VM

Actual results:

Service does not start

Expected results:

Service should start automatically.


Additional info:

Comment 1 Lev Veyde 2014-06-08 09:22:03 UTC
My mistake...

I debugged it and it is due to the way Python's win32serviceutil module works.
By default the service is installed in manual mode, unless a command line option is supplied to change this behaviour (-auto).

Will fix this in the oVirt WGT installer.

Comment 2 Jiri Belka 2014-07-24 11:47:49 UTC
ovirt GT 3.5.5 has automatic for the service.

Comment 3 Sandro Bonazzola 2014-10-17 12:40:07 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.