Bug 1105673 - Face dependencies issue when pulp-puppet-module-builder is run on non sat6box
Summary: Face dependencies issue when pulp-puppet-module-builder is run on non sat6box
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: Mike McCune
QA Contact: Kedar Bidarkar
URL:
Whiteboard:
Depends On: 1145713
Blocks: 1317008 sat6-pulp-future 1175448 sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2014-06-06 17:19 UTC by Kedar Bidarkar
Modified: 2019-08-12 16:07 UTC (History)
17 users (show)

Fixed In Version: pulp-puppet-2.8.3-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1145713 (view as bug list)
Environment:
Last Closed: 2016-07-27 11:17:23 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Pulp Redmine 538 High CLOSED - CURRENTRELEASE Face dependencies issue when pulp-puppet-module-builder is run on non sat6box 2016-05-17 20:02:38 UTC

Description Kedar Bidarkar 2014-06-06 17:19:23 UTC
Description of problem:
Using Puppet GIT tool (pulp-puppet-module-builder) to create puppet repos, on a non sat6box, fails creating puppet git repositories due to dependency issues/Import Errors.

We face this error when trying on a non-sat6 box, 

[root@xxxx puppet]# pulp-puppet-module-builder --url=https://github.com/puppetlabs/puppetlabs-xinetd -o ../modules
Traceback (most recent call last):
  File "/usr/bin/pulp-puppet-module-builder", line 9, in <module>
    load_entry_point('pulp-puppet-tools==2.4.0', 'console_scripts', 'pulp-puppet-module-builder')()
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 299, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2229, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 1948, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
ImportError: No module named pulp_puppet.tools.puppet_module_builder
[root@dhcp201-151 puppet]# rpm -ql pulp-puppet-tools.noarch
/usr/bin/pulp-puppet-module-builder
/usr/lib/python2.6/site-packages/pulp_puppet/tools
/usr/lib/python2.6/site-packages/pulp_puppet/tools/__init__.py
/usr/lib/python2.6/site-packages/pulp_puppet/tools/__init__.pyc
/usr/lib/python2.6/site-packages/pulp_puppet/tools/__init__.pyo
/usr/lib/python2.6/site-packages/pulp_puppet/tools/puppet_module_builder.py
/usr/lib/python2.6/site-packages/pulp_puppet/tools/puppet_module_builder.pyc
/usr/lib/python2.6/site-packages/pulp_puppet/tools/puppet_module_builder.pyo
/usr/lib/python2.6/site-packages/pulp_puppet_tools-2.4.0-py2.6.egg-info
/usr/lib/python2.6/site-packages/pulp_puppet_tools-2.4.0-py2.6.egg-info/PKG-INFO
/usr/lib/python2.6/site-packages/pulp_puppet_tools-2.4.0-py2.6.egg-info/SOURCES.txt
/usr/lib/python2.6/site-packages/pulp_puppet_tools-2.4.0-py2.6.egg-info/dependency_links.txt
/usr/lib/python2.6/site-packages/pulp_puppet_tools-2.4.0-py2.6.egg-info/entry_points.txt
/usr/lib/python2.6/site-packages/pulp_puppet_tools-2.4.0-py2.6.egg-info/top_level.txt
/usr/share/doc/pulp-puppet-tools-2.4.0
/usr/share/doc/pulp-puppet-tools-2.4.0/AUTHORS
/usr/share/doc/pulp-puppet-tools-2.4.0/COPYRIGHT
/usr/share/doc/pulp-puppet-tools-2.4.0/LICENSE


 

Installing "pulp-puppet-tools" pkg, should pull in "python-pulp-puppet-common" pkg as well. 

There could be other deps as well.


Version-Release number of selected component (if applicable):
sat6-snap8-compose2

How reproducible:


Steps to Reproduce:
1. 
2.
3.

Actual results:
Unable to run "pulp-puppet-module-builder --url=https://github.com/puppetlabs/puppetlabs-xinetd -o ../modules" on a non sat6 box

Expected results:
should be able to run "pulp-puppet-module-builder --url=https://github.com/puppetlabs/puppetlabs-xinetd -o ../modules" on a non sat6 box


Additional info:

Comment 1 Mike McCune 2014-06-06 17:23:21 UTC
WORKAROUND:

# yum -y install pulp-puppet-module-builder python-setuptools python-pulp-puppet-common 

you need the extra few packages in that above yum command.

Comment 2 Corey Welton 2014-06-06 17:28:44 UTC
This entire function will require documentation, specifically about telling users how to install a subset of packages in order to be able to use a remote repo as a source for a satellite.

Comment 7 Michael Hrivnak 2014-12-17 21:13:35 UTC
This fix is in 2.6.0 upstream, which will be in sat 6.1.

Comment 14 pulp-infra@redhat.com 2015-04-23 16:40:17 UTC
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.

Comment 15 David O'Brien 2015-06-09 15:06:23 UTC
Is this still required for Sat6.1 rel notes? It was included in the 6.0 notes.

https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.0/html-single/Release_Notes/index.html#Packaging

thanks

Comment 16 Kedar Bidarkar 2015-08-06 15:16:25 UTC
yes this release note is still required for satellite6.1.

Comment 20 Kedar Bidarkar 2016-03-21 12:48:21 UTC
Can I get some info as to, which package this bug needs to be tested if this is fixed or which repos should be enabled to resolve the deps?

Currently I tried with the package: pulp-puppet-tools-2.8.0.1-2.beta.el7sat.noarch.rpm

 ~]# pulp-puppet-module-builder --url=https://github.com/puppetlabs/puppetlabs-xinetd -o ./modules
Traceback (most recent call last):
  File "/usr/bin/pulp-puppet-module-builder", line 9, in <module>
    load_entry_point('pulp-puppet-tools==2.8.0b7', 'console_scripts', 'pulp-puppet-module-builder')()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 378, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2566, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2260, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
ImportError: No module named pulp_puppet.tools.puppet_module_builder

I feel installing package "pulp-puppet-tools" should also pull in the below packages as dependency,
a) python-setuptools,
b) python-pulp-puppet-common 

This is not fixed yet with "pulp-puppet-tools" package.

Comment 23 pulp-infra@redhat.com 2016-03-22 22:31:24 UTC
The Pulp upstream bug status is at NEW. Updating the external tracker on this bug.

Comment 30 pulp-infra@redhat.com 2016-03-31 14:34:46 UTC
The Pulp upstream bug status is at ASSIGNED. Updating the external tracker on this bug.

Comment 31 pulp-infra@redhat.com 2016-03-31 18:34:37 UTC
The Pulp upstream bug status is at POST. Updating the external tracker on this bug.

Comment 32 Kedar Bidarkar 2016-03-31 20:07:36 UTC
Installing pulp-puppet-tools packages should pull in all the deps, which still does not happend with the package version pulp-puppet-tools.noarch 0:2.8.0.2-1.el7sat


1) Installing "pulp-puppet-tools.noarch 0:2.8.0.2-1.el7sat" package should also pull in,
a) python-setuptools,
b) python-pulp-puppet-common 


2) We can now find all the  required packages  in sattools repo

a) pulp-puppet-tools
b) python-pulp-puppet-common 





As seen below dependency resolution still fails.

~]# pulp-puppet-module-builder --url=https://github.com/puppetlabs/puppetlabs-xinetd -o ./modules
Traceback (most recent call last):
  File "/usr/bin/pulp-puppet-module-builder", line 9, in <module>
    load_entry_point('pulp-puppet-tools==2.8.0', 'console_scripts', 'pulp-puppet-module-builder')()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 378, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2566, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2260, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
ImportError: No module named pulp_puppet.tools.puppet_module_builder

Comment 34 pulp-infra@redhat.com 2016-04-04 21:04:45 UTC
The Pulp upstream bug status is at MODIFIED. Updating the external tracker on this bug.

Comment 35 David O'Brien 2016-04-18 00:47:40 UTC
Reset docs contact <> daobrien

Comment 36 pulp-infra@redhat.com 2016-04-26 23:05:24 UTC
The Pulp upstream bug status is at ON_QA. Updating the external tracker on this bug.

Comment 37 pulp-infra@redhat.com 2016-05-17 20:02:39 UTC
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.

Comment 40 Kedar Bidarkar 2016-06-02 14:11:08 UTC
We can now run the command "pulp-puppet-module-builder --url=https://github.com/puppetlabs/puppetlabs-xinetd -o ../modules" without any dependency issues.

Installing a) pulp-puppet-tools also installs b) python-pulp-puppet-common as dependency without having to install it separately.


VERIFIED with sat62-snap(GA)-13.1

Comment 41 Kedar Bidarkar 2016-06-02 15:17:33 UTC
Sorry it was VERIFIED with sat62-snap(GA)-14.0

Comment 42 Bryan Kearney 2016-07-27 11:17:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.