Bug 110692 - bad source code
bad source code
Status: CLOSED DUPLICATE of bug 116249
Product: Fedora
Classification: Fedora
Component: anacron (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-23 11:02 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2003-11-23 11:02:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:

I just tried to compile package anacron-2_3-29 from Fedora.

The compiler said

gregor.c(68): warning #300: const variable "isleap" requires an 
initializer
      const int isleap; /* save three calls to leap() */
                      ^

gregor.c(79): error #137: expression must be a modifiable lvalue
      isleap = leap(year);
      ^

compilation aborted for gregor.c (code 2)
make: *** [gregor.o] Error 2

Sounds like some work is required to get the declaration and
initialisation of isleap together.


Version-Release number of selected component (if applicable):
2_3-29 

How reproducible:
Always

Steps to Reproduce:
1. compile with ISO C compiler
2.
3.
    

Additional info:
Comment 1 Miloslav Trmac 2004-04-21 13:53:36 EDT

*** This bug has been marked as a duplicate of 116249 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.