Bug 116249 - patch for ISO C
patch for ISO C
Status: CLOSED DUPLICATE of bug 121006
Product: Fedora
Classification: Fedora
Component: anacron (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Brock Organ
:
: 110692 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-19 10:07 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2004-02-19 10:07:04 EST
Description of problem:

Here is patch to get anacron-2.3-29 to compile on ISO C
compilers.

--- gregor.c.orig	2004-02-19 12:40:10.000000000 +0000
+++ gregor.c	2004-02-19 12:40:41.000000000 +0000
@@ -65,7 +65,6 @@
 {
     int dn;
     int i;
-    const int isleap; /* save three calls to leap() */
 
     /* Some validity checks */
 
@@ -76,7 +75,7 @@
     if (month > 12 || month < 1) return - 1;
     if (day < 1) return - 1;
   
-    isleap = leap(year);
+    const int isleap = leap(year); /* save three calls to leap() */
   
     if (month != 2) {
 	if(day > days_in_month[month - 1]) return - 1;


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Miloslav Trmac 2004-04-21 13:53:38 EDT
*** Bug 110692 has been marked as a duplicate of this bug. ***
Comment 2 Miloslav Trmac 2004-04-21 13:57:39 EDT
The patch in bug 121006 is slightly better (it does not require C99
support).

*** This bug has been marked as a duplicate of 121006 ***

*** This bug has been marked as a duplicate of 121006 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:01:26 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.