Bug 110759 - openssl-devel package should Requires: zlib-devel
openssl-devel package should Requires: zlib-devel
Status: CLOSED DUPLICATE of bug 102962
Product: Red Hat Raw Hide
Classification: Retired
Component: openssl (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-24 09:55 EST by Maxim Dziumanenko
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maxim Dziumanenko 2003-11-24 09:55:28 EST
Description of problem:
-lz specified in /usr/lib/pkgconfig/openssl.pc (which belongs to
openssl-devel), thus openssl-devel package should Requires: zlib-devel

Version-Release number of selected component (if applicable):
openssl-0.9.7a-23

How reproducible:
Always

Steps to Reproduce:
1.rpm -i openssl-devel 
2.rpm -e zlib-devel
3.rpmbuil --rebuild libsoup-2.4.0-3.src.rpm (which depends on
openssl-devel, but doesn't directly depend on zlib-devel)
4. Wait for build errors
  
Actual results:


Expected results:


Additional info:
Comment 1 Nalin Dahyabhai 2003-11-24 10:03:04 EST

*** This bug has been marked as a duplicate of 102962 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.