Bug 1107743 - assigning provisioning template to operating system is not straight forward
Summary: assigning provisioning template to operating system is not straight forward
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning Templates
Version: Nightly
Hardware: Unspecified
OS: Unspecified
high
medium vote
Target Milestone: Unspecified
Assignee: Ohad Levy
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1120716 1144004 (view as bug list)
Depends On:
Blocks: 1122832
TreeView+ depends on / blocked
 
Reported: 2014-06-10 14:00 UTC by Jan Hutař
Modified: 2019-09-25 21:14 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-13 20:11:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6370 None None None 2016-04-22 16:23:02 UTC

Description Jan Hutař 2014-06-10 14:00:23 UTC
Description of problem:
Assigning provisioning template to operating system is not straight forward - requires multiple steps which seems redundant to me and if they are not, there is not enough inline help/tips helping to explain the problem


Version-Release number of selected component (if applicable):
Satellite-6.0.3-RHEL-6-20140605.0


How reproducible:
always


Steps to Reproduce:
1. Create operating system
2. Hosts -> Provisioning templates -> Kickstart default user data ->
     -> Association -> check checkbox nex to <your_operating_system> -> Submit
3. Hosts -> Operating systems -> <your_operating_system> -> Templates ->
     -> select "Kickstart default user data" in "user_data" drop-down element ->
     -> Submit


Actual results:
Steps 2. or 3. seems redundant to me


Expected results:
One of steps 2. or 3. might be redundant, or webUI could be altered to help me to understand this is needed (e.g. some hints added?)

Comment 2 Dominic Cleal 2014-06-25 06:55:53 UTC
Created redmine issue http://projects.theforeman.org/issues/6370 from this bug

Comment 3 Dominic Cleal 2014-09-25 13:04:41 UTC
*** Bug 1144004 has been marked as a duplicate of this bug. ***

Comment 4 Stephen Benjamin 2014-10-14 14:57:03 UTC
*** Bug 1120716 has been marked as a duplicate of this bug. ***

Comment 5 Stephen Benjamin 2014-11-21 00:48:42 UTC
Starting with 6.1 (and already in Katello 2.0), the situation is improved a little.

When an operating system with a distribution is synchronized for the first time, the dual associations will be made and there's no steps for the user.  

In the Settings (Katello tab), you may configure which templates are used for those initial associations if you want to use your own.

The underlying usability issue still needs to be resolved though, especially if the one wants to provision an OS that's content doesn't come from Katello.

Comment 7 Bryan Kearney 2015-08-25 17:24:10 UTC
Upstream bug component is WebUI

Comment 8 Bryan Kearney 2015-08-25 17:36:44 UTC
Upstream bug component is Provisioning Templates

Comment 9 Tomas Strachota 2016-09-01 10:55:46 UTC
I'm lowering severity to medium. It is serious usability issue but once it's set it doesn't disrupt any operation.

Comment 10 Bryan Kearney 2017-03-13 20:11:06 UTC
This has been copied to an issue upstream. When the upstream issue is fixed, the next version of satellite will contain it. We will no longer track this downstream.

Comment 11 Lukas Zapletal 2018-06-13 14:18:21 UTC
For the record, this upstream ticket should make the UX better: https://projects.theforeman.org/issues/23923


Note You need to log in before you can comment on or make changes to this bug.