Bug 110789 - bad source code
bad source code
Status: CLOSED DUPLICATE of bug 110788
Product: Fedora
Classification: Fedora
Component: kakasi (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Bill Huang
Depends On:
  Show dependency treegraph
Reported: 2003-11-24 11:01 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:00:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description d.binderman 2003-11-24 11:01:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:

I just tried to compile package kakasi-2_3_4-13 from Fedora.

The compiler said


k2.c(157): warning #175: subscript out of range

The source code is

char buffer[k2rom_buflen];

/* more code */

buffer[k2rom_buflen] = '\0'; clen = k2rom_buflen;

Array limits in C are exclusive, not inclusive.


libk2.c(157): warning #175: subscript out of range

Same problem again.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. by  inspection

Additional info:
Comment 1 Akira TAGOH 2003-11-25 04:09:43 EST

*** This bug has been marked as a duplicate of 110788 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.