Bug 110805 - installclass.py has no "xconfig" default
installclass.py has no "xconfig" default
Status: CLOSED DUPLICATE of bug 105586
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-24 11:29 EST by Joshua Jensen
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2003-11-24 11:29:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030807


Description of problem:
The docs say that xconfig doesn't have to have the --card or --monitor
arguments, and if left out anaconda would use what is found when
probing. I can see that my monitor and video card are ddcprobed for, and
detected perfectly.... but anaconda complains that it didn't find any
sane defaults, and says this when "xconfig" is on a line by itself:

File "user/lib/anaconda/installclass.py", line 461, in configureX
  self.setMiscXSettigns(id, depth, resolution, runlevel = rl)
File "/usr/lib/anaconda/installclass.py", line 366, in setMiscXsettings
  id.xsetup.xhwsetup.choose_sane_default()
AttributeError:  XSetup instance has no attribute 'xhwsetup'



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Make a valid ks.cfg file, test it to be sure it works
2. remove all args to the xconfig line in said ks.cfg
3. watch anaconda traceback =)
    

Expected Results:  According to the docs, xconfig needs no arguments.
 Can Red Hat please fix this... I could see this being a sensible
logic path:

1)  Use the monitor/card specified to xconfig in ks.cfg, else

2)  autodetect monitor/card and uses that to match the list of known
monitors/cards, then use the specs from the matching entries on the
list, else

3)  use the raw dccprobe specs for monitor, detect or guess card, else

4)  with no information whatsoever, (but "^xconfig$" still present in
ks.cfg), choose super-generic defaults for monitor/card.

Additional info:

I can actually use the installer from Fedora if this is fixed there...
please provide feedback regardless.
Comment 1 Jeremy Katz 2003-11-24 17:17:55 EST
This is in the queue of things for the first update (and is fixed in
FC1 since that's a later codebase)

*** This bug has been marked as a duplicate of 105586 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.