Bug 105586 - kickstart install with probed monitor fails
kickstart install with probed monitor fails
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
: 110805 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-09-25 17:10 EDT by Alexandre Oliva
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-09 01:27:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This patch restores the relevant behavior from Severn 1, fixing the problem. (744 bytes, patch)
2003-09-25 17:12 EDT, Alexandre Oliva
no flags Details | Diff

  None (edit)
Description Alexandre Oliva 2003-09-25 17:10:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
Kickstart install on a laptop with monitor TOS5082 fails.  The xconfig line is:

xconfig  --depth 24 --resolution 1024x768 --defaultdesktop=GNOME --startxonboot

The end of the backtrace looks a bit like this:

xhwstate.py:546: available_resolutions
monitor.py:387: monitor_supports_mode
monitor.py:375: list_from_string
string.py:122: split
AttributeError: 'NoneType' object has no attribute 'split'

The problem is in installclass.py.  hsync and vsync are None in the
auto-probe case, and the call to lookupMonitorByName sets vert and
horiz, not hsync and vsync, so they remain unset.  When we call
set_hsync and set_vsync, we're using None objects, so recalc_mode uses bogus
information.
Comment 1 Alexandre Oliva 2003-09-25 17:12:15 EDT
Created attachment 94740 [details]
This patch restores the relevant behavior from Severn 1, fixing the problem.

Although the patch fixes the problem, arranging for the probed horiz and vert
to make it to hsync and vsync when they were unset might be a better
alternative.
Comment 2 Jeremy Katz 2003-09-25 19:38:24 EDT
Fixed (went slightly differently with the fix, though)

diff -u -u -r1.200 installclass.py
--- installclass.py     20 Sep 2003 03:31:26 -0000      1.200
+++ installclass.py     25 Sep 2003 23:37:46 -0000
@@ -392,13 +392,13 @@
         if usemon:
             monname = usemon
             try:
-                (model, eisa, vert, horiz) = id.monitor.lookupMonitorByName(usemon)
+                (model, eisa, vsync, hsync) =
id.monitor.lookupMonitorByName(usemon)
                if id.monitor.getMonitorID() != "DDCPROBED":
                    useid = model
                else:
                    useid = "DDCPROBED"
                     
-                id.monitor.setSpecs(horiz, vert, id=useid, name=model)
+                id.monitor.setSpecs(hsync, vsync, id=useid, name=model)
                 setmonitor = 1
             except:
                 log("Couldnt lookup monitor type %s." % usemon)
Comment 3 Alexandre Oliva 2003-09-25 21:08:48 EDT
But your fix will override user-specified values with probed ones.  I don't
think we should do this.
Comment 4 Jeremy Katz 2003-09-29 16:46:48 EDT
That's what happens anyway, this doesn't change that behavior (as setmonitor
gets set to 1 and so your provided values don't get used anyway)

Tweaked a little bit more.
Comment 5 Jeremy Katz 2003-11-24 17:17:57 EST
*** Bug 110805 has been marked as a duplicate of this bug. ***
Comment 6 Jay Turner 2004-01-16 12:15:52 EST
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-344.html
Comment 7 Mike MacCana 2004-02-01 22:33:48 EST
Instructor Central needs an updated RHCX iso (based on the update 1
boot.iso) to install on hardware where this bug is apparent.

Though using boot.iso and typing the options manually seems like a
decent workaround till then.

Would reopen, but can't.

Note You need to log in before you can comment on or make changes to this bug.