Bug 1108106 - Content Host : Bulk actions need to be updated to use dynflow
Summary: Content Host : Bulk actions need to be updated to use dynflow
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hosts
Version: 6.0.3
Hardware: All
OS: Linux
high
high vote
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact:
URL:
Whiteboard:
: 1177189 1294944 1374669 1627845 (view as bug list)
Depends On:
Blocks: 1528275
TreeView+ depends on / blocked
 
Reported: 2014-06-11 13:02 UTC by Brad Buckingham
Modified: 2020-04-15 14:20 UTC (History)
22 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1528275 (view as bug list)
Environment:
Last Closed: 2016-07-27 08:41:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2110131 None None None 2020-04-15 14:20:12 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Brad Buckingham 2014-06-11 13:02:10 UTC
Description of problem:

The content host bulk actions need to be converted to dynflow and the UI updated to enable the user to see progress and completion of those actions.

Version-Release number of selected component (if applicable):
sat6.0.3

How reproducible:
always

Steps to Reproduce:
1. Hosts -> Content Hosts 
2. select a couple of content hosts
3. Click 'Bulk Actions'
4. go to Packages or Errata
5. perform an action

Actual results:
The action is initiated; however, there is no indication to the user that it is being executed.  In addition, there is no history of the action upon completion.

Expected results:
If possible, we should show the user progress of the action being executed.  In order to support this, we should update the bulk actions to use dynflow and provide a similar task status/progress to what we show today for other actions.

Additional info:

Comment 2 Ekin Meroglu 2015-02-28 22:57:11 UTC
This is present in current Satellite (6.0.7), and a popular pain point among our users. Most of them use Satellite for applying mass errata, and this issue makes monitoring and reporting -almost- impossible...

Comment 4 Fred van Zwieten 2015-03-30 12:40:56 UTC
(In reply to Ekin Meroglu from comment #2)
> This is present in current Satellite (6.0.7), and a popular pain point among
> our users. Most of them use Satellite for applying mass errata, and this
> issue makes monitoring and reporting -almost- impossible...

So is there currently a workaround for this?

Comment 5 Ekin Meroglu 2015-03-30 14:00:33 UTC
(In reply to Fred van Zwieten from comment #4)

> So is there currently a workaround for this?

AFAIK, no - You have to wait for sometime to let the updates finish, and then check each one of the clients for the result...

Comment 8 Brad Buckingham 2015-12-11 20:09:24 UTC
*** Bug 1177189 has been marked as a duplicate of this bug. ***

Comment 10 glennduffy 2015-12-17 21:16:16 UTC
It seems that this issue is actually two issues. One is that bulk package installations don't produce any status. The other is that bulk errata updates don't produce any status. As far as I see, the latter has been addressed in Satellite 6.1. However, the former (bulk package installations) has not yet been fixed. Should this be filed as a separate issue or maintained here?

Comment 14 Brad Buckingham 2016-01-27 12:13:05 UTC
Hello Glen,
Regarding comment 10, we can continue to track the changes needed for the bulk package actions using this bugzilla.

Comment 15 Justin Sherrill 2016-03-08 00:17:06 UTC
As part of Satellite 6.2 The remote execution feature has been added and provides this functionality via dynflow and a tracked task.  Old katello-agent style actions will remain as they are in 6.1.

Moving to ON_QA to validate for bulk package actions view Remote execution

Comment 16 Stephen Benjamin 2016-03-24 16:01:37 UTC
Verified, bulk actions via remote execution forward to job status page, where the user can watch the progress live.

Comment 19 errata-xmlrpc 2016-07-27 08:41:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Comment 20 Justin Sherrill 2016-12-19 20:49:49 UTC
*** Bug 1374669 has been marked as a duplicate of this bug. ***

Comment 21 Justin Sherrill 2016-12-21 19:43:16 UTC
*** Bug 1294944 has been marked as a duplicate of this bug. ***

Comment 22 Brad Buckingham 2017-09-20 20:23:44 UTC
*** Bug 1418993 has been marked as a duplicate of this bug. ***

Comment 24 Brad Buckingham 2018-09-28 13:13:28 UTC
*** Bug 1627845 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.