Bug 1108402 - epel-7-x86_64 builds fail because RHEL 7 RC packages removed
Summary: epel-7-x86_64 builds fail because RHEL 7 RC packages removed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mock
Version: 20
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1111088 1117842 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-12 00:20 UTC by Vinson Lee
Modified: 2014-11-10 22:42 UTC (History)
8 users (show)

Fixed In Version: mock-1.1.41-3.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-10 16:04:15 UTC
Type: Bug


Attachments (Terms of Use)

Description Vinson Lee 2014-06-12 00:20:51 UTC
Description of problem:
Red Hat has removed RHEL 7 RC packages. mock epel-7-x86_64 builds are no longer possible.

Version-Release number of selected component (if applicable):
1.1.39

How reproducible:
100%

Steps to Reproduce:
1. mock -r epel-7-x86_64 <srpm>
2.
3.

Actual results:
INFO: Results and/or logs in: /var/lib/mock/epel-7-x86_64/result
ERROR: Command failed: 
 # ['/usr/bin/yum', '--installroot', '/var/lib/mock/epel-7-x86_64/root/', 'install', '@buildsys-build', '--setopt=tsflags=nocontexts']
http://ftp.redhat.com/pub/redhat/rhel/rc/7/Server/x86_64/os/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.


 One of the configured repositories failed (el),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Disable the repository, so yum won't use it by default. Yum will then
        just ignore the repository until you permanently enable it again or use
        --enablerepo for temporary usage:

            yum-config-manager --disable el

     4. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=el.skip_if_unavailable=true

failure: repodata/repomd.xml from el: [Errno 256] No more mirrors to try.
http://ftp.redhat.com/pub/redhat/rhel/rc/7/Server/x86_64/os/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found


Expected results:


Additional info:

Comment 1 Miroslav Suchý 2014-06-12 09:10:42 UTC
Well for time being  this url works:
  baseurl=http://kojipkgs.fedoraproject.org/rhel/beta/7/x86_64/os/
but I hesitate to commit this url in mock as it can cause overload of Koji.
I think we need to wait for ordinary Centos and the put there centos url.
Till then I am putting it on back burner.

Comment 2 Miroslav Suchý 2014-06-19 08:40:00 UTC
*** Bug 1111088 has been marked as a duplicate of this bug. ***

Comment 3 Björn 'besser82' Esser 2014-06-19 08:57:14 UTC
How about using [1]?  That should be able to solve the problem for now , until there will be something final.

[1] http://buildlogs.centos.org/centos/7/os/x86_64-latest/repodata/repomd.xml

Comment 4 Miroslav Suchý 2014-07-07 14:27:01 UTC
Centos 7 is coming close to release and final urls (and even epel7) works.
Commited to msuch-work branch as commit 2764a44

I removed ppc64, because centos7 is not released for ppc64 and that RHEL RC does not work any more.

Comment 5 Miroslav Suchý 2014-07-14 12:28:21 UTC
*** Bug 1117842 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2014-07-18 02:13:18 UTC
mock-1.1.40-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mock-1.1.40-2.fc20

Comment 7 Fedora Update System 2014-07-18 02:13:44 UTC
mock-1.1.40-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.40-2.fc19

Comment 8 Fedora Update System 2014-07-18 02:14:07 UTC
mock-1.1.40-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.1.40-2.el6

Comment 9 Fedora Update System 2014-07-18 17:45:24 UTC
mock-1.1.41-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mock-1.1.41-1.fc20

Comment 10 Fedora Update System 2014-07-18 17:45:51 UTC
mock-1.1.41-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.41-1.fc19

Comment 11 Fedora Update System 2014-07-18 17:46:17 UTC
mock-1.1.41-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.1.41-1.el6

Comment 12 Fedora Update System 2014-07-19 05:58:07 UTC
Package mock-1.1.41-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mock-1.1.41-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8492/mock-1.1.41-1.fc20
then log in and leave karma (feedback).

Comment 13 Fedora Update System 2014-07-20 03:24:32 UTC
mock-1.1.41-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2014-07-22 18:07:52 UTC
mock-1.1.41-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Alan Pevec 2014-08-28 09:29:18 UTC
> Commited to msuch-work branch as commit 2764a44

Please also add el7 extras repo [*]
 http://mirrorlist.centos.org/?release=7&arch=x86_64&repo=extras

EPEL7 depends on it, packages previously in EPEL7 have been blocked if they're in EL7 Extras so Copr EL7 buildroot setup fails e.g.
DEBUG util.py:283:  Error: Package: 1:python-flask-0.10.1-3.el7.noarch (epel)
DEBUG util.py:283:             Requires: python-itsdangerous


[*] see https://fedoraproject.org/wiki/EPEL/epel7
EPEL7 depends on rhel-7-server-extras-rpms, rhel-7-server-optional-rpms, rhel-7-server-rpms and rhel-ha-for-rhel-7-server-rpms
Optional and HA seem to be included in CentOS7 base repo but Extras is separate.

Comment 16 Miroslav Suchý 2014-08-28 11:46:25 UTC
Addressed in commit bdba516 in msuchy-work branch.

Comment 17 Fedora Update System 2014-09-16 16:46:52 UTC
mock-1.1.41-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.41-2.fc19

Comment 18 Fedora Update System 2014-09-19 10:03:33 UTC
Package mock-1.1.41-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mock-1.1.41-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-10998/mock-1.1.41-2.fc19
then log in and leave karma (feedback).

Comment 19 Fedora Update System 2014-09-30 09:00:07 UTC
mock-1.1.41-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.41-3.fc19

Comment 20 Fedora Update System 2014-10-10 16:04:15 UTC
mock-1.1.41-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Tim Flink 2014-11-10 22:42:55 UTC
Was the fix for this supposed to add the extras repo to epel-7 mock configs in f20?

I'm using mock-1.1.41-3.fc20 and the extras repo is not part of the epel-7 configs


Note You need to log in before you can comment on or make changes to this bug.