Bug 110887 - ab - apachebench timeouts in apr_poll
ab - apachebench timeouts in apr_poll
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-25 04:29 EST by Ales Ledvinka
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 2.0.48-1.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-08 11:17:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Ledvinka 2003-11-25 04:29:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4)
Gecko/20030624

Description of problem:
running apachebench against apache or tomcat gives

apr_poll: * timeout * (70007)

ab -n 1000 -c 10 http://localhost:80/index.html
ab -n 1000 -c 10 http://localhost:80/index.php
ab -n 1000 -c 10 http://localhost:8080/index.jsp
...

same with keepalives allowed.
apache bench does open sockets to server (exactly the number specified
as concurency parametr)

stacing ab shows it opens socket sets nodelay flag does connect which
returns einprogress and then apachebench waits in poll until it timeouts.

it is not firewall problem - telnet localhost 80 works as expected
it is not server configuration problem - running ab from some unknown
version of mandrake against mentioned servers returns results as expected.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install fedora minimal
2.rpm -i http* php-4*
3.ab ... as shown in description
    

Actual Results:  apr_poll: * timeout * (70007)

Expected Results:  run and give some numbers.

Additional info:

could it be because of apache/apache runtime rewrite?
Comment 1 Joe Orton 2003-11-25 04:55:50 EST
This is fixed in the 2.0.48 update: see bug 108608 for location of
packages.
Comment 2 Jan Pazdziora 2003-12-20 12:15:49 EST
I'm confirming that the httpd-2.0.48-1.2 fixes the problem for me.
Comment 3 Joe Orton 2004-01-08 11:17:10 EST
Thanks for testing it!  The update has now been issued.

Note You need to log in before you can comment on or make changes to this bug.