This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 110989 - up2date fails to access yum repositories over proxy exclusively
up2date fails to access yum repositories over proxy exclusively
Status: CLOSED DUPLICATE of bug 102272
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-26 07:09 EST by Nils Philippsen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/etc/sysconfig/rhn/sources (2.92 KB, text/plain)
2003-11-26 07:10 EST, Nils Philippsen
no flags Details
/etc/sysconfig/rhn/up2date (3.37 KB, text/plain)
2003-11-26 07:12 EST, Nils Philippsen
no flags Details

  None (edit)
Description Nils Philippsen 2003-11-26 07:09:56 EST
Description of problem:

[...]
root@gibraltar:~> /usr/bin/up2date -u
 
Fetching package list for channel: fedora-core-1...
 
Fetching
http://wftp.tu-chemnitz.de/pub/linux/fedora-core/1/i386/os/headers/header.info...
There was some sort of I/O error: <urlopen error (-2, 'Name or service
not known')>
root@gibraltar:~>
[...]

Version-Release number of selected component (if applicable):

up2date-4.1.16-1

How reproducible:

Easily.

Steps to Reproduce:
1. Setup a machine so that DNS doesn't resolve the YUM repository
host(s), only the http proxy
2. Configure up2date to use proxy and to use YUM repositories
3. run "up2date -u"
  
Actual results:

Seee above

Expected results:

No traceback, machine gets updated

Additional info:

Apparently it looks up the hosts (and fails) even though configured to
use a proxy. When configured for a proxy, it shouldn't attempt to
resolve the hosts at all.
Comment 1 Nils Philippsen 2003-11-26 07:10:49 EST
Created attachment 96208 [details]
/etc/sysconfig/rhn/sources
Comment 2 Nils Philippsen 2003-11-26 07:12:20 EST
Created attachment 96209 [details]
/etc/sysconfig/rhn/up2date
Comment 3 Michael Young 2003-11-26 10:46:21 EST
triage->duplicate 107036
Duplicate of bug 107036, see also bug 102272
Comment 4 Nils Philippsen 2003-11-27 02:59:11 EST

*** This bug has been marked as a duplicate of 102272 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:00:11 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.