Bug 111132 - glibc emulation for ia32 doesn't work
glibc emulation for ia32 doesn't work
Status: CLOSED DUPLICATE of bug 107116
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-27 21:18 EST by Shinya Narahara
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shinya Narahara 2003-11-27 21:18:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
The binary compiled on ia34 with shared library,
doesn't work on ia64 RedHat Enterprise Linux 3.

The sample is below:
#include <errno.h>
extern int errno;
main() {
  char *syscmd="mkdir '/tmp/xxxx'" ;
  int   sysrc = 0;
  printf("command = %s\n",syscmd);
  sysrc = system(syscmd);
  printf("system = %d\n",sysrc);
  printf("errno  = %d %s\n",errno,strerror(errno));
}


Version-Release number of selected component (if applicable):
glibc-2.3.2-95.3

How reproducible:
Always

Steps to Reproduce:
1.compile the sample on ia32 with shared library
2.execute the binary on ia64
3.
    

Actual Results:  
command = mkdir '/tmp/xxxx'
system = -1
errno  = 14 Bad address


Expected Results:  
command = mkdir '/tmp/xxxx'
system = 0
errno  = 0

Additional info:

Same binary works fine on RH72 for IA64.
Also fine the binary is compiled statically on ia32.
The source file works properly on ia32 with compiling ia32,
or on ia64 with compiling ia64. 

Is this a bug of /emul/ia32-linux/lib/*.so ?
Comment 1 Arjan van de Ven 2003-12-02 09:44:07 EST

*** This bug has been marked as a duplicate of 107116 ***
Comment 2 Arjan van de Ven 2003-12-02 09:46:14 EST
also your code is broken:
#include <errno.h>
extern int errno;

is very very invalid
Comment 3 Shinya Narahara 2003-12-04 20:44:09 EST
> also your code is broken:
> #include <errno.h>
> extern int errno;
> is very very invalid

The program validity is not essential.
We just tell you that "system()" system call doesn't work on
RHAS3 for IA64, although this works on RH72 for IA64.

Comment 4 Red Hat Bugzilla 2006-02-21 14:00:12 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.