Bug 111135 - gmp-devel with wrong symlink for libgmpxx.so
gmp-devel with wrong symlink for libgmpxx.so
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gmp (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
: 111994 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-28 06:20 EST by Gilles J. Seguin
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-02 03:05:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch remove a offending line creating a bad symlink for libgmpxx.so (644 bytes, patch)
2003-11-28 06:26 EST, Gilles J. Seguin
no flags Details | Diff

  None (edit)
Description Gilles J. Seguin 2003-11-28 06:20:13 EST
Description of problem: bad symlink


Version-Release number of selected component (if applicable):
gmp-devel-4.1.2-9.i386.rpm

How reproducible:
not applicable

Steps to Reproduce:
1.
2.
3.
  
Actual results:
$ ls -l /usr/lib/libgmpxx.so
give -> /usr/lib/gmpxx.so.3
which is not a existing file or link

Expected results:
At least point to /usr/lib/libgmpxx.so.3 or 3.1.4

Additional info:
see patch file for a line commented out from spec file.
Comment 1 Gilles J. Seguin 2003-11-28 06:26:39 EST
Created attachment 96233 [details]
patch remove a offending line creating a bad symlink for libgmpxx.so
Comment 2 Miloslav Trmac 2003-11-28 11:51:10 EST
Patch looks correct.
rpm -q --whatrequires gmpxx.so.3 --dbpath
/usr/lib/rpmdb/i386-redhat-linux/redhat/
indicates gmpxx.so.3 is not used by anyone.

Additionally, the package doesn't build on FC1 due to its usage
of LIBTOOL=/usr/bin/libtool; it sets CXX to i386-redhat-linux-c++,
but /usr/bin/libtool knows only "c++".
Comment 3 Florian La Roche 2003-12-02 03:05:06 EST
Fixed the broken link, the rpm seems to rebuild fine for me.

greetings and thanks for the bug-report,

Florian La Roche
Comment 4 Bill Nottingham 2003-12-12 11:37:06 EST
*** Bug 111994 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.