Bug 111140 - mod_php does not seem to reset variables from php.ini if a .htaccess has modified them
mod_php does not seem to reset variables from php.ini if a .htaccess has modi...
Status: CLOSED DUPLICATE of bug 110861
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-28 09:14 EST by Kalle Kataja
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kalle Kataja 2003-11-28 09:14:17 EST
Description of problem:
I found out that the httpd process that has once read php variables 
from a .htaccess file, in my case the following: 

php_value 
include_path ".:/var/www/donjohnsonbigband.com/php/:/var/www/donjohnso
nbigband.com"

in my php.ini the initial value is:

include_path = ".:/usr/local/php";

Now, I ran into a problem that's hard to fix with any workaround; it 
seems to me, that the httpd process, once been to the directory with 
that particular .htaccess file, will have the php module remember the 
value, and not reset it back to the one in php.ini. This causes other 
pages to bug randomly (apparently if they are served by process(es) 
visited that directory).

I'm not sure if this is the actual thing that happens, but the 
include_path is randomly wrong.


Version-Release number of selected component (if applicable):
httpd-2.0.47-10
php-4.3.3-6

How reproducible:


Steps to Reproduce:
1. make a .htaccess file modify the include_path
2. request a php page from the directory with the .htaccess file
3. repeat requests to php pages in other directories that try to 
require a file that should be found in a directory defined in php.ini
  
Actual results:
some requests to the php pages in step 3 fail

Expected results:
all requests should work

Additional info:

Linux meizo 2.4.22-1.2115.nptlsmp #1 SMP Wed Oct 29 15:30:09 EST 2003 
i686 i686 i386 GNU/Linux
Comment 1 Kalle Kataja 2003-11-28 09:58:00 EST
I had missed out that this seems to be the same bug as 110861. sorry 
about that

*** This bug has been marked as a duplicate of 110861 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:13 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.