Bug 1111783 (RHEV_SCSI_reserve_Win_DirectLUN) - [RFE][TestOnly] Provide SCSI reservation support for virtio-scsi via rhev-guest-tools for win-8 and win-2012 guests using Direct-Lun as disks
Summary: [RFE][TestOnly] Provide SCSI reservation support for virtio-scsi via rhev-gue...
Keywords:
Status: CLOSED ERRATA
Alias: RHEV_SCSI_reserve_Win_DirectLUN
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ovirt-4.3.0
: 4.3.0
Assignee: Ryan Barry
QA Contact: Petr Matyáš
URL:
Whiteboard:
Depends On: 769712 1452210 1464908 1470007 1484075 1519019 1519021
Blocks: 1638746
TreeView+ depends on / blocked
 
Reported: 2014-06-21 12:52 UTC by Anand Nande
Modified: 2019-08-13 04:25 UTC (History)
26 users (show)

Fixed In Version: ovirt-engine-4.3.0_alpha
Doc Type: Enhancement
Doc Text:
In the current release, Windows clustering is supported for directly attached LUNs and shared disks.
Clone Of:
: 1638746 (view as bug list)
Environment:
Last Closed: 2019-05-08 12:35:59 UTC
oVirt Team: Virt
Target Upstream Version:
sherold: Triaged+
jbelka: testing_plan_complete-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1077 None None None 2019-05-08 12:36:29 UTC
oVirt gerrit 86864 'None' 'MERGED' 'spec: Require device-mapper-multipath for SCSI reservations' 2019-11-11 21:50:09 UTC
oVirt gerrit 88566 'None' 'MERGED' 'core: iscsi reservation' 2019-11-11 21:50:09 UTC
oVirt gerrit 94889 'None' 'MERGED' 'core: add a vdc_option for SCSI Reservations' 2019-11-11 21:50:09 UTC
Red Hat Bugzilla 1111784 'high' 'CLOSED' '[RFE] Provide SCSI reservation support for virtio-scsi via rhev-guest-tools for win-8 and win-2012 guests using Shared ... 2019-11-11 21:50:08 UTC
Red Hat Knowledge Base (Solution) 2937021 None None None 2017-11-08 15:22:24 UTC

Internal Links: 1111784

Comment 10 Yaniv Lavi 2016-12-05 13:00:59 UTC
This is a Virt feature and should be ready on RHEL 7.3 right?
Can you pick this one up?

Comment 11 Yaniv Lavi 2017-01-09 15:55:48 UTC

*** This bug has been marked as a duplicate of bug 1111784 ***

Comment 12 Michal Skrivanek 2017-02-07 11:57:10 UTC
there were several tests in bug 1111784, they may be relevant here for direct lun disks. Jiri, can you please update?

Comment 13 Jiri Belka 2017-02-07 12:08:58 UTC
It does not work with RHV. There is an investigation in progress. See https://bugzilla.redhat.com/show_bug.cgi?id=1111784#c71

Comment 28 Sandro Bonazzola 2017-12-12 13:53:10 UTC
Please check if this can be moved to ON_QA

Comment 36 Michal Skrivanek 2018-05-04 14:22:34 UTC
updating the status to reflect we're not yet ready across the whole stack

Comment 41 Sandro Bonazzola 2018-09-13 08:52:30 UTC
4.2.6 has been released, please re-target

Comment 45 Petr Matyáš 2018-12-11 14:54:12 UTC
I've played around this, but I still have no idea what is the point of this bug or how to verify, so can you please provide verification steps and differences from bug#1111784.

Comment 46 Ryan Barry 2018-12-11 15:13:28 UTC
The point of this bug is essentially to allow Windows clustering using SCSI reservations. To verify, attempt to set up a Windows cluster on RHV with reservations set.

The difference between this and 1111783 is that it is with direct LUNs multiple VMs rather than a shared disk

Comment 47 Petr Matyáš 2018-12-11 15:58:48 UTC
OK, another question, I'm trying to verify the cluster, but I always fail on List Disks To Be Validated with error:

Failed while verifying removal of any Persistent Reservation on physical disk {fb774468-f63c-4b06-bdfb-7ae147053c58} at node WIN-2012R2.ad-w2k12r2.somewhere.at.redhat.com.

And so Validate SCSI-3 Persistent Reservation is not run at all.

Is there some way to clear persistent reservations or is problem somewhere else? Google was no help up to now (I've been trying to find a solution for some hours now)

Comment 48 Ryan Barry 2018-12-11 16:18:33 UTC
It looks like this must be done manually. Have you tried the instructions here? https://blogs.technet.microsoft.com/bulentozkir/2015/04/22/handling-persistent-reservation-failures-in-windows-2012-r2-and-windows-2012/

Comment 49 Petr Matyáš 2018-12-11 16:58:30 UTC
Yep, the first method gives me I/O device error and the other method also does not work as service list says cluster service is disabled (no devices associated with it), so maybe I'm missing something here?

Comment 50 Ryan Barry 2018-12-11 17:01:01 UTC
Is this a new disk/lun, or pre-existing?

Comment 51 Petr Matyáš 2018-12-11 17:04:08 UTC
This was new LUN on which I created FS (NTFS) and I have it attached to both VMs

Comment 52 Ryan Barry 2018-12-11 17:22:37 UTC
Can you provide me access to the test environment?

Comment 55 Petr Matyáš 2018-12-13 15:19:14 UTC
After trying again it still fails with the same error on List Disks To Be Validated so SCSI Reservations are not tested.
Even after unchecking and checking again SCSI reservations in RHVM.

Same env as before if you would like to check the VMs.

Comment 57 Michal Skrivanek 2019-01-28 13:59:55 UTC
I think it should be moved. mtessun managed to test it, but we need a proper TP and someone maintaining the testing effort

Comment 59 Eli Marcus 2019-02-18 11:17:44 UTC
Updated the doc text to match https://bugzilla.redhat.com/show_bug.cgi?id=1111784 

"With this release, Windows clustering is supported for based direct attached LUNs and shared disks."

Comment 60 Petr Matyáš 2019-02-28 13:17:15 UTC
So finally I found out what the problem was with my setup and the SCSI reservation is working all right.

Verified on vdsm-4.30.9-1.el7ev.x86_64

Comment 64 errata-xmlrpc 2019-05-08 12:35:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1077


Note You need to log in before you can comment on or make changes to this bug.