Bug 111196 - trying to view mod_python manual returns 500 Internal Server Error
Summary: trying to view mod_python manual returns 500 Internal Server Error
Status: CLOSED DUPLICATE of bug 127622
Alias: None
Product: Fedora
Classification: Fedora
Component: mod_python   
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL: http://localhost/manual/mod/mod_pytho...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-29 17:50 UTC by Juha Sahakangas
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A simple patch to python.conf which solves the problem. (434 bytes, patch)
2003-11-29 17:52 UTC, Juha Sahakangas
no flags Details | Diff

Description Juha Sahakangas 2003-11-29 17:50:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016

Description of problem:
Browsing to http://localhost/manual/mod/mod_python/ returns an Apache
internal server error due to erroneous default configuration.

Default httpd configuration for /var/www/manual puts a type-map
handler for *.html files, allowing multiple language versions of the
actual content.

Mod python documentation however doesn't follow the same scheme and
are instead normal .html files which break the type-map handler and
cause error page to be displayed.

This could fixed by providing the necessary type map files and
renaming actual html pages, but this would be rather pointless since
there aren't versions of these pages in languages other than english.

Perhaps better fix is to just modify the configuration so type maps
are not expected to be found in this subdirectory.

Version-Release number of selected component (if applicable):
3.0.3-3

How reproducible:
Always

Steps to Reproduce:
1. Open location http://localhost/manual/mod/mod_python/ in any web
browser.


Actual Results:  Apache internal server error page is displayed.


Expected Results:  Mod_python manual front page is shown.

Additional info:

Comment 1 Juha Sahakangas 2003-11-29 17:52:31 UTC
Created attachment 96249 [details]
A simple patch to python.conf which solves the problem.

Overrides the type-map handler with default one for files in directory
/var/www/manual/mod/mod_python

Comment 2 Joe Orton 2005-02-01 16:29:45 UTC

*** This bug has been marked as a duplicate of 127622 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:00:13 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.