Bug 127622 - Accessing http://localhost/manual/mod/mod_python gives internal server error
Accessing http://localhost/manual/mod/mod_python gives internal server error
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mod_python (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
: EasyFix
: 111196 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-11 07:38 EDT by Nils Philippsen
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-29 10:16:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to set default-handler as the handler for HTML files beneath /var/www/manual/mod/mod_python (469 bytes, patch)
2004-07-11 07:42 EDT, Nils Philippsen
no flags Details | Diff
Patch to set default-handler as the handler for HTML files beneath /var/www/manual/mod/mod_python (485 bytes, patch)
2004-07-13 02:43 EDT, Nils Philippsen
no flags Details | Diff

  None (edit)
Description Nils Philippsen 2004-07-11 07:38:36 EDT
Description of problem:

FC2 httpd has "SetHandler type-map" for *.html files beneath
/var/www/manual, but mod_python documentation doesn't provide type-map
files but rather plain *.html files.

Version-Release number of selected component (if applicable):

mod_python-3.1.3-1

How reproducible:

Always.

Steps to Reproduce:
1. With the local httpd started, go to
http://localhost/manual/mod/mod_python/
  
Actual results:

Internal Server Error

The server encountered an internal error or misconfiguration and was
unable to complete your request.
[...]

Expected results:

mod_python documentation

Additional info:

Will attach small patch for /etc/httpd/conf.d/python.conf that sets
default-handler for mod_python documentation HTML files instead of
type-map.
Comment 1 Nils Philippsen 2004-07-11 07:42:30 EDT
Created attachment 101789 [details]
Patch to set default-handler as the handler for HTML files beneath /var/www/manual/mod/mod_python
Comment 4 Nils Philippsen 2004-07-13 02:43:20 EDT
Created attachment 101851 [details]
Patch to set default-handler as the handler for HTML files beneath /var/www/manual/mod/mod_python

Change comment line
Comment 5 Nils Philippsen 2004-07-29 10:16:09 EDT
Fixed in mod_python-3.1.3-1.fc2.1
Comment 6 Joe Orton 2005-02-01 11:29:52 EST
*** Bug 111196 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.