Bug 111212 - Up2date no channel for fedora...
Up2date no channel for fedora...
Status: CLOSED DUPLICATE of bug 114530
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-30 02:19 EST by Dereck Martin
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dereck Martin 2003-11-30 02:19:42 EST
Description of problem:

Please reference ticket# 105649 it is similar to mine, but different
versions.

I am trying to register my Fedora Core system using the Up2Date
Utility.  AFter I registered.  ITs giving me this error when trying to
update material.  ITs preventing me from updating anything.  Its also
stating in my RHN Profile that I am using RedHat 1.0 ... 

======================================================================
Error Message:
    Please run rhn_register (or up2date --register on Red Hat Linux 8.0)
as root on this client
Error Class Code: 9
Error Class Info: Invalid System Credentials.
Explanation:
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.
======================================================================

This is the profle that is listed in my RHN.

System Properties
Profile Name: 	gurus.homelinux.org
Entitlement: 	Demo
Notifications: 	Errata Email
Auto Errata Update: 	Auto Errata Update only available for paying accounts
Buy Now
Description: 	Initial Registration Parameters:
OS: Red Hat Linux
Release: 1
CPU Arch: i686-redhat-linux
Location: 	(none)

======================================================================

Also the up2date agent gives this after trying to register

Invalid Architecture and OS release combination (1, i686-redhat-linux).
Your system has been registered, but will not receive updates 
because it is not subscribed to a channel. If you have not yet
activated your product for service, please visit our website at:
  
     http://www.redhat.com/now

...to activate your product.

======================================================================

Version-Release number of selected component (if applicable): 

Up2Date Agent: latest release


How reproducible: Everytime


Steps to Reproduce:
1. run rhn_register or up2date --register 
2. run up2date
3.
  
Actual results: unable to lovate the fedora core channel, or a the
channel responsible for fedora core


Expected results: ability to reside with a channel for fedora


Additional info:
Comment 1 Anastasios Zafiropoulos 2004-02-09 16:53:16 EST
I think that this issue with up2date in combination with the 
rhn_register command is well documented in bug ID :114530

If you comment out the line "up2date default" in 
the /etc/sysconfig/rhn/sources file you will no longer have problems 
with channel subscriptions, RHN registrations and weird things that 
actually ARE useless (from my point of view) for the fedora distro.
This is because fedora users, do not have any option to alter their 
channel subscriptions from the RHN official site.
However, that used to be a very usefull utility for the Redhat 
distros, where you were able to subscripe your system in a channel 
like "updates" and have it been automatically updated with up2date.

So 2 options are available:
1. Either the official support from Redhat Network will stop 
completelly for Fedora or 
2. Developers will modify the programs, not to include the 
rhn_register option for the users

Since my participation in redhat bugzilla is very limited, i don't 
alter the status of this "BUG". But if my information was usefull, 
than, someone plz change the status of this "BUG"

Regards
Anastasios Zafeiropoulos
Greece
Comment 2 Grant Hill 2004-02-10 09:34:08 EST
triage->duplicate #114530
Comment 3 Miloslav Trmac 2004-02-10 12:27:38 EST

*** This bug has been marked as a duplicate of 114530 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:00:14 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.