Bug 114530 - up2date bug: Invalid Architecture and OS release combination
up2date bug: Invalid Architecture and OS release combination
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
1
athlon Linux
high Severity high
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
: 111212 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-29 01:43 EST by Slan
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-29 09:23:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Slan 2004-01-29 01:43:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
When I run 'up2date --register', up2date is sending info about my
system to RHN and in this moment I get information:

"Invalid Architecture and OS release combination (1, athlon-redhat-linux).
Your system has been registered, but will not receive updates 
because it is not subscribed to a channel. If you have not yet
activated your product for service, please visit our website at:
  
     http://www.redhat.com/now

...to activate your product."

and I'm not subscribed to any channel and can't download any updates
:( What is wrong? I don't know :( Please help.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. I opened rhn.redhat.com and in my account, at bookmark "Systems" I
have my registered system, but both positions: "Software Channel
Subscriptions" and "Base Software Channel" are empty.
2. I choice button "System Entitlements" at the left and I get table
with properties about my account and in this table position "Base
Channel" is "(empty)".
3. I did delete my system and send again by up2date, but I get the
same information: "Invalid Architecture and OS release combination..."
Comment 1 Jef Spaleta 2004-01-29 09:23:58 EST
I just attempted to confirm this.

up2date --register  doesn't appear to do anything for me.
I don't expect it to either. For Fedora Core 1, up2date comes
configured to use public yum package repositories and not rhn. AFAIK
rhn channel for Fedora Core 1 is not available. 
Please make sure you are using the correct up2date sources file for
Fedora Core 1, and not an older left over from an upgrade from a
version of rhl or a test release.
/etc/sysconfig/rhn/sources
run the command 'rpm -V up2date'
if the sources file shows up in the list from rpm -V, its a good bet
that file is not the correct default sources file.

the line 'up2date default' should be commented out and you should have
lines starting with  'yum fedora-core-1' 'yum updates-released'
uncommented.

I've gotten confirmation from other people running 'up2date
--register' on fc1 systems and they confirm that with the correct
sources file  that command quickly returns with no effort to
communicate with the user.  If however the 'up2date default' line in
the sources file is uncommented, --register, does prompt the user for
interaction.

I'm marking this report as NOTABUG.

 
Comment 2 Slan 2004-01-29 15:22:48 EST
I'll remove up2date with up2date-gnome and install it again. In this 
moment all is OK. I not must register on RHN and I can download 
updates. Thanks for your help :)
Comment 3 Brian Beaudoin 2004-02-08 02:55:14 EST
Ran into this issue as well - having been a paying customer to Red Hat
for so long made me think that I could use my account (hah!)

It's definitely the registration that causes the problem.  Of course,
for the first few times I used 'up2date' after reinstalling, it kept
prompting me to register again!  Not very intuitive.
Comment 4 Miloslav Trmac 2004-02-10 12:27:43 EST
*** Bug 111212 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.