Bug 1112165 - dracut-mount[1799]: Warning: /sysroot has no proper rootfs layout, ignoring and removing offending mount hook
Summary: dracut-mount[1799]: Warning: /sysroot has no proper rootfs layout, ignoring a...
Keywords:
Status: CLOSED DUPLICATE of bug 1112315
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: rawhide
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: dracut-maint-list
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ARMTracker
TreeView+ depends on / blocked
 
Reported: 2014-06-23 09:18 UTC by Alexander Todorov
Modified: 2014-06-25 13:25 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-25 13:25:02 UTC


Attachments (Terms of Use)

Description Alexander Todorov 2014-06-23 09:18:52 UTC
Description of problem:

As far as I can see installation of latest Rawhide fails to start with dracut failing to mount the rootfs of the installation image. I see two errors and I'm not sure which one is the root cause of the problem. 


From a bunch of failed automated installs (from console.log) I see:

   
] Reached target Initrd File Systems.  
         Starting dracut mount hook...  
[   36.316596] dracut-mount[1006]: Warning: /sysroot has no proper rootfs layout, ignoring and removing offending mount hook  
[   36.770521] dracut-mount[1006]: Warning: Can't mount root filesystem  
         Starting Dracut Emergency Shell... 
 
Generating "/run/initramfs/rdsosreport.txt" 
 
 
Entering emergency mode. Exit the shell to continue. 
Type "journalctl" to view system logs. 
You might want to save "/run/initramfs/rdsosreport.txt" to a USB stick or /boot 
after mounting them and attach it to a bug report. 
 
 
dracut:/# [-- MARK -- Mon Jun 23 08:05:00 2014] 




On one particular hardware I also see a kernel oops then the same error as above:

] Reached target System Initialization. 
         Starting Show Plymouth Boot Screen... 
[   16.250932] net enp0s10f0: Using EEPROM-set media 100baseTx-FDX 
[   16.253576] ------------[ cut here ]------------ 
[   16.254335] WARNING: CPU: 0 PID: 665 at lib/dma-debug.c:1140 check_unmap+0x4e6/0x9a0() 
[   16.254432] tulip 0000:00:0a.0: DMA-API: device driver failed to check map error[device address=0x000000003020abd8] [size=192 bytes] [mapped as single] 
[   16.254432] Modules linked in: hv_netvsc hv_storvsc hid_hyperv crc32c_intel tulip hv_vmbus ata_generic pata_acpi sunrpc dm_crypt dm_round_robin linear raid10 raid456 async_raid6_recov async_memcpy async_pq async_xor xor async_tx raid6_pq raid1 raid0 iscsi_ibft iscsi_boot_sysfs floppy iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi squashfs cramfs edd dm_multipath 
[   16.254432] CPU: 0 PID: 665 Comm: ip Not tainted 3.16.0-0.rc1.git4.1.fc21.i686 #1 
[   16.254432] Hardware name: Microsoft Corporation Virtual Machine/Virtual Machine, BIOS 090004  03/19/2009 
[   16.254432]  00000000 67a95be1 00000000 f0817de4 c0afd7a0 f0817e28 f0817e18 c0458792 
[   16.254432]  c0d07bc8 f0817e48 00000299 c0d05af4 00000474 c0762316 00000474 c0762316 
[   16.254432]  f0b0f0e0 f037fb40 c0cb5443 f0817e34 c04587ee 00000009 f0817e28 c0d07bc8 
[   16.254432] Call Trace: 
[   16.254432]  [<c0afd7a0>] dump_stack+0x48/0x60 
[   16.254432]  [<c0458792>] warn_slowpath_common+0x82/0xa0 
[   16.254432]  [<c0762316>] ? check_unmap+0x4e6/0x9a0 
[   16.254432]  [<c0762316>] ? check_unmap+0x4e6/0x9a0 
[   16.254432]  [<c04587ee>] warn_slowpath_fmt+0x3e/0x60 
[   16.254432]  [<c0762316>] check_unmap+0x4e6/0x9a0 
[   16.254432]  [<c0497ab7>] ? sched_clock_cpu+0x107/0x150 
[   16.254432]  [<c0762842>] debug_dma_unmap_page+0x72/0x90 
[   16.254432]  [<f7d8d0cc>] tulip_interrupt+0x85c/0xfc0 [tulip] 
[   16.254432]  [<c07b6ee5>] ? acpi_os_release_lock+0xd/0xf 
[   16.254432]  [<c07cf0ea>] ? acpi_ev_sci_xrupt_handler+0x59/0x62 
[   16.254432]  [<c04c8416>] handle_irq_event_percpu+0x76/0x310 
[   16.254432]  [<c04cb74a>] ? handle_fasteoi_irq+0x1a/0x140 
[   16.254432]  [<c04c86e1>] handle_irq_event+0x31/0x50 
[   16.254432]  [<c04cb79b>] handle_fasteoi_irq+0x6b/0x140 
[   16.254432]  [<c04cb730>] ? unmask_threaded_irq+0x40/0x40 
[   16.254432]  [<c0405a80>] handle_irq+0x90/0xd0 
[   16.254432]  <IRQ>  [<c040508c>] do_IRQ+0x3c/0xd0 
[   16.254432]  [<c0b068b8>] common_interrupt+0x38/0x40 
[   16.254432]  [<c0b05503>] ? _raw_spin_unlock_irqrestore+0x33/0x60 
[   16.254432]  [<f7d90d58>] set_rx_mode+0x418/0x630 [tulip] 
[   16.254432]  [<c09d4dc9>] ? dev_set_rx_mode+0x19/0x30 
[   16.254432]  [<c09d4d6b>] __dev_set_rx_mode+0x4b/0x90 
[   16.254432]  [<c09d4dd0>] dev_set_rx_mode+0x20/0x30 
[   16.254432]  [<c09d4eba>] __dev_open+0xda/0x150 
[   16.254432]  [<c0b054bf>] ? _raw_spin_unlock_bh+0x2f/0x40 
[   16.254432]  [<c09d51aa>] __dev_change_flags+0x8a/0x160 
[   16.254432]  [<c09d52a8>] dev_change_flags+0x28/0x60 
[   16.254432]  [<c09e2ee3>] do_setlink+0x2d3/0x7c0 
[   16.254432]  [<c075fe32>] ? nla_parse+0x22/0xe0 
[   16.254432]  [<c09c9cd3>] ? netdev_master_upper_dev_get+0x13/0x70 
[   16.254432]  [<c09e5448>] rtnl_newlink+0x628/0x7a0 
[   16.254432]  [<c040c108>] ? sched_clock+0x8/0x10 
[   16.254432]  [<c04b0018>] ? __lock_is_held+0x48/0x70 
[   16.254432]  [<c06ca0bc>] ? selinux_capable+0x2c/0x40 
[   16.254432]  [<c06c4fbc>] ? security_capable+0x1c/0x30 
[   16.254432]  [<c0462980>] ? ns_capable+0x30/0x70 
[   16.254432]  [<c09ff072>] ? __netlink_ns_capable+0x32/0x40 
[   16.254432]  [<c09e1f0f>] rtnetlink_rcv_msg+0x8f/0x220 
[   16.254432]  [<c09e1e67>] ? rtnetlink_rcv+0x17/0x30 
[   16.254432]  [<c0a00cb3>] ? netlink_deliver_tap+0x83/0x270 
[   16.254432]  [<c09e1e67>] ? rtnetlink_rcv+0x17/0x30 
[   16.254432]  [<c09e1e80>] ? rtnetlink_rcv+0x30/0x30 
[   16.254432]  [<c0a03a8e>] netlink_rcv_skb+0x8e/0xb0 
[   16.254432]  [<c09e1e73>] rtnetlink_rcv+0x23/0x30 
[   16.254432]  [<c0a03129>] netlink_unicast+0x109/0x1b0 
[   16.254432]  [<c0a03459>] netlink_sendmsg+0x289/0x720 
[   16.254432]  [<c04b0146>] ? lock_release_holdtime.part.28+0x96/0xf0 
[   16.254432]  [<c09b49bd>] sock_sendmsg+0x7d/0xc0 
[   16.254432]  [<c0745664>] ? _copy_from_user+0x54/0x60 
[   16.254432]  [<c09c3667>] ? verify_iovec+0x57/0xc0 
[   16.254432]  [<c09b569f>] ___sys_sendmsg.part.17+0x2ff/0x310 
[   16.254432]  [<c04b0146>] ? lock_release_holdtime.part.28+0x96/0xf0 
[   16.254432]  [<c04b563d>] ? lock_release_non_nested+0x30d/0x320 
[   16.254432]  [<c04b0146>] ? lock_release_holdtime.part.28+0x96/0xf0 
[   16.254432]  [<c0587d11>] ? might_fault+0x51/0xb0 
[   16.254432]  [<c0587d11>] ? might_fault+0x51/0xb0 
[   16.254432]  [<c0587d11>] ? might_fault+0x51/0xb0 
[   16.254432]  [<c0587d67>] ? might_fault+0xa7/0xb0 
[   16.254432]  [<c0745664>] ? _copy_from_user+0x54/0x60 
[   16.254432]  [<c09b62b0>] __sys_sendmsg+0x50/0x90 
[   16.254432]  [<c09b6fc6>] SYSC_socketcall+0x836/0xa10 
[   16.254432]  [<c040c108>] ? sched_clock+0x8/0x10 
[   16.254432]  [<c0497749>] ? sched_clock_local+0x49/0x180 
[   16.254432]  [<c0497ab7>] ? sched_clock_cpu+0x107/0x150 
[   16.254432]  [<c04b0146>] ? lock_release_holdtime.part.28+0x96/0xf0 
[   16.254432]  [<c058b7d4>] ? handle_mm_fault+0x614/0xb80 
[   16.254432]  [<c04b0018>] ? __lock_is_held+0x48/0x70 
[   16.254432]  [<c0446764>] ? __do_page_fault+0x294/0x5d0 
[   16.254432]  [<c04ae86b>] ? up_read+0x1b/0x30 
[   16.254432]  [<c0446764>] ? __do_page_fault+0x294/0x5d0 
[   16.254432]  [<c09b7283>] SyS_socketcall+0x13/0x20 
[   16.254432]  [<c0b061af>] sysenter_do_call+0x12/0x38 
[   16.254432] ---[ end trace ef114331757db6ac ]--- 
[   16.254432] Mapped at: 
[   16.254432]  [<c0760e73>] debug_dma_map_page+0x63/0x130 
[   16.254432]  [<f7d90ccf>] set_rx_mode+0x38f/0x630 [tulip] 
[   16.254432]  [<c09d4d6b>] __dev_set_rx_mode+0x4b/0x90 
[   16.254432]  [<c09d4dd0>] dev_set_rx_mode+0x20/0x30 
[   16.254432]  [<c09d4eba>] __dev_open+0xda/0x150 
[   16.385763] ip (665) used greatest stack depth: 5036 bytes left 
         Mounting Configuration File System...  
[    
  OK

Comment 2 Alexander Todorov 2014-06-23 09:20:40 UTC
dracut-037-13.git20140402.fc21 (Initramfs)

Comment 3 Paul Whalen 2014-06-24 14:30:48 UTC
Affects all arches (arm, i386, x86_64).

Comment 4 satellitgo 2014-06-24 16:02:52 UTC
seen in boot.iso 20140624; 20140623; 20140622 (VirtualBox)

Comment 5 satellitgo 2014-06-25 12:47:19 UTC
(In reply to satellit from comment #4)
> seen in boot.iso 20140624; 20140623; 20140622 (VirtualBox)

boot.iso    20140625 also

Comment 6 David Shea 2014-06-25 13:25:02 UTC
The failure is that the squashfs image is not identified as such.

*** This bug has been marked as a duplicate of bug 1112315 ***


Note You need to log in before you can comment on or make changes to this bug.