Bug 1112315 - blkid fails to identify squashfs
blkid fails to identify squashfs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 1112165 (view as bug list)
Depends On:
Blocks: ARMTracker F21AlphaBlocker
  Show dependency treegraph
 
Reported: 2014-06-23 11:07 EDT by David Shea
Modified: 2014-06-26 04:13 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-25 18:05:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Correct the return values in squashfs probe (1.31 KB, patch)
2014-06-23 13:39 EDT, David Shea
no flags Details | Diff

  None (edit)
Description David Shea 2014-06-23 11:07:36 EDT
Description of problem:
blkid -s TYPE -u noraid -o value squashfs.img

with util-linux-2.24.2-6.fc21.x86_64, this prints "squashfs" and returns 0. With util-linux-2.25-0.1.fc21.x64_64, it prints nothing and returns 2.

This is preventing rawhide install images from booting.

Version-Release number of selected component (if applicable):

util-linux-2.25-0.1.fc21.x86_64
Comment 1 David Shea 2014-06-23 13:39:37 EDT
Created attachment 911529 [details]
Correct the return values in squashfs probe

Patch correcting the issue attached.
Comment 2 David Shea 2014-06-23 13:47:05 EDT
(In reply to David Shea from comment #1)
> Created attachment 911529 [details]
> Correct the return values in squashfs probe
> 
> Patch correcting the issue attached.

And forwarded upstream
Comment 3 Karel Zak 2014-06-24 06:11:35 EDT
Fedora package will be fixed after update to util-linux v2.25-rc2.
Comment 4 Adam Williamson 2014-06-24 19:08:53 EDT
This is an automatic release blocker, per https://fedoraproject.org/wiki/QA:SOP_blocker_bug_process#Automatic_blockers :

"Complete failure of any release-blocking TC/RC image to boot at all under any circumstance - "DOA" image (conditional failure is not an automatic blocker)"

marking as such.
Comment 5 David Shea 2014-06-25 09:25:02 EDT
*** Bug 1112165 has been marked as a duplicate of this bug. ***
Comment 6 Kevin Fenzi 2014-06-25 17:12:38 EDT
When is v2.25-rc2 due out?

If it's going to be a bit, can we backport the fix and at least get rawhide installs working again?

I'll be happy to go and do that later today...
Comment 7 Adam Williamson 2014-06-25 18:05:04 EDT
pjones sent a build with the fix backported through today. next nightlies should be fixed.
Comment 8 Karel Zak 2014-06-26 04:13:28 EDT
Thanks! :-)

Note You need to log in before you can comment on or make changes to this bug.