This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 11128 - netscape communicator crashes at odd times.
netscape communicator crashes at odd times.
Status: CLOSED DUPLICATE of bug 2711
Product: Red Hat Linux
Classification: Retired
Component: netscape (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-30 12:02 EDT by John B. Brown
Modified: 2014-03-16 22:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-02 13:01:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John B. Brown 2000-04-30 12:02:45 EDT
When I set any java or javascript preference the browser dies without a
trace; ps reveals no trace of the browser.
Comment 1 John B. Brown 2000-04-30 12:08:59 EDT
This problem started some while ago. It continues even after replacing 4.61 with
4.72-6 components. All three parts from netscape for linux (glibc-2) are
installed. This is my second submission for this bug. The first bug report seems
to have magically disappeared.
Comment 2 Bill Nottingham 2000-05-01 12:13:59 EDT
This happens when you just turn on java/javascript
in the preferences, not when you go to a
java-containing page?
Comment 3 John B. Brown 2000-05-01 22:01:59 EDT
Only when visiting or on a page using java somehow. I can turn off java and
javascript, visit the same page and/or hit the same button or URL and there is
no crash. It crashes from URL buttons and sometimes from the middle of a load
sequence when a page is partly loaded. It may have a pattern but I can't
discerne one..
Comment 4 John B. Brown 2000-05-01 22:12:59 EDT
The updated versions came from one of the mirror archives listed on the redhat
ftp site, not from netscape.com. It was maybe msu.edu or umich.edu or maybe
unc.edu; I forget which but it was the one that had the redhat material and was
fast into u-mass-boston.

I find I can't set this navigator applications preferences to save a file with
.rpm suffix so I ftp to boston, use gzip on the package, download from Boston to
Buffalo, Wyoming, and then unzip and rpm the packages. All very tedious because
the damned thing wont save an rpm package to a file.
Comment 5 Bill Nottingham 2000-05-02 13:01:59 EDT
*** This bug has been marked as a duplicate of 2711 ***
Comment 6 John B. Brown 2000-05-03 22:47:59 EDT
The suggestion to run chkfontpath was tried a while ago.
/usr/X11R6/lib/X11/fonts/75dpi' is already present. Along with a large number of
other fonts probably added by acroread inatall. Experimenting with a known crash
site, www.sluggy.com, I have discovered that javascript being set is a prime
cause of a crash. If the site is loaded and one clicks on any day in the past
archive calendar there is an immediate die of netscape communicator. This also
happens on certain quicken.com sites. There is also a nice little notice from
quicken telling me I cannot navigate through their site using a browser that is
not javascript enabled. Very not nice!
I find the safest way to avoid netscape crashes is to set load images and unset
the rest, along with refusing all cookies. If I need cookies to buy something I
can set the limited accept and review each cookie. But that is small potatoes
compared to the unexpected an unpredictable crash of my browser!
The kernel is 2.2.14 int, glibc-2.1.3 int., gcc-2.95.2 crypt, netscape 128bit
4.7.2-6 from the redhat mirror.
Its the java problem. There is a notice on the suggy site proclaiming the
universality of the java problem on all current netscape browsers. Their site
will crash any netscape browser set for java and javascript. They know it and
state it openly. Its a netscape java bug. Not being a mozilla afficionado I
haven't the first clue where to start in that pile of mozilla source.

HELP!

Note You need to log in before you can comment on or make changes to this bug.